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FIX: You may have problems when you add lots of IP addresses on the network adapter of a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

On a Windows Server 2003-based computer, you add lots of IP addresses on the network adapter. Then, you may experience one or more of the following problems even if you restart the computer:
  • When you right-click any of the network interfaces, you receive the following error message:
    An unexpected error occurred.
  • You cannot display the details of the events in the event log. Additionally, you receive the following error message:
    No properties are available on this object
  • You cannot display the event properties by double-clicking the event in Event Viewer.
  • When you type Tasklist.exe /svc at the command prompt and then press ENTER, you receive the following error message:
    Error: No such interface supported
  • If you add Device Manager to the Microsoft Management Console (MMC), the toolbar is displayed correctly. However, the details pane is blank.
  • An access violation occurs in the ole32!DsaValid method of the Network Connections service (Netman.dll). The Network Connections service (Netman.dll) runs in the context of the Service Host Process (Svchost.exe).
  • You can start Windows Internet Explorer, but then Internet Explorer closes immediately. If you attach a debugger to the Iexplorer.exe file, you receive the following error message in the debugger when Internet Explorer closes:
    0x000006B5 - RPC_S_UNKNOWN_IF
    The interface is unknown.
  • When you connect to any namespace in Windows Management Instrumentation (WMI) Tester (Wbemtest.exe), you receive the following error message:
    Error Number: 0x80004002
    Facility: <Null>
    Description: No such interface supported
  • When you start Windows Management Instrumentation Management (Wmimgmt.msc), the General tab is displayed. However, you cannot connect to the local computer.
  • When you type msinfo32 in the Run dialog box, you receive the following error message:
    Can't Collect Information
    Cannot access the Windows Management Instrumentation software. Windows Management file may be moved or missing.
The number of IP addresses rests on the number that is used in each octet of the address (for example, 1.1.1.1 vs. 192.168.123.123). But, the number of IP addresses was reported at approximately 2,000 to 2,500.

Note These issues do not occur on a Windows 2000-based computer.

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Cause

When so many IP addresses are configured, data corruption occurs. Therefore, the Network Connections service (Netman.dll) crashes.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problems that are described in this article. Apply this hotfix only to systems that are experiencing the problems described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed to apply this hotfix.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
x86 versions on Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.32021,250,30429-Aug-200816:10x86SP1SP1QFE
Ole32.dll5.2.3790.44151,269,76022-Nov-200820:34x86SP2SP2QFE
x64 versions on Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.32022,550,78429-Aug-200813:59x64SP1SP1QFE
Wole32.dll5.2.3790.32021,250,30429-Aug-200813:59x86SP1WOW
Ole32.dll5.2.3790.44152,626,04822-Nov-200819:15x64SP2SP2QFE
Wole32.dll5.2.3790.44151,269,76022-Nov-200819:15x86SP2WOW
IA-64 versions on Windows Server 2003
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.32023,998,20829-Aug-200813:59IA-64SP1SP1QFE
Wole32.dll5.2.3790.32021,250,30429-Aug-200813:59x86SP1WOW
Ole32.dll5.2.3790.44154,101,63222-Nov-200819:07IA-64SP2SP2QFE
Wole32.dll5.2.3790.44151,269,76022-Nov-200819:07x86SP2WOW

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Workaround

To work around these problems, decrease the number of IP addresses until these problems no longer occur.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Call stack output

0:002> k100
ChildEBP RetAddr  
00b0f2c8 77686e60 ole32!DsaValid+0x31
00b0f2f0 776a42af ole32!WriteObjRef+0x157
00b0f374 776a444b ole32!CStdMarshal::MarshalInterface+0xb7
00b0f3a4 776a43d1 ole32!StdMarshalObject+0x6b
00b0f400 776a3984 ole32!CDestObjectWrapper::MarshalInterface+0x150
00b0f43c 77686f6b ole32!CoMarshalInterface+0x93
00b0f490 77686e20 ole32!MarshalHelperMulti+0x48
00b0f4bc 77686d2e ole32!GetInstanceHelperMulti+0x4d
00b0f584 77c70f4b ole32!CObjServer::CreateInstance+0x30d
00b0f5a8 77ce23f7 rpcrt4!Invoke+0x30
00b0f9a8 77ce1a95 rpcrt4!NdrStubCall2+0x299
00b0fa00 77788ec1 rpcrt4!CStdStubBuffer_Invoke+0xc6
00b0fa44 77788e74 ole32!SyncStubInvoke+0x33
00b0fa8c 7769b2b7 ole32!StubInvoke+0xa7
00b0fb64 7769b0b5 ole32!CCtxComChnl::ContextInvoke+0xe3
00b0fb80 77789926 ole32!MTAInvoke+0x1a
00b0fbb0 77788c33 ole32!AppInvoke+0xa3
00b0fc84 77789936 ole32!ComInvokeWithLockAndIPID+0x2c5
00b0fcd0 77c709ce ole32!ThreadInvoke+0x1e0
00b0fd04 77c7094f rpcrt4!DispatchToStubInCNoAvrf+0x38
00b0fd58 77c70875 rpcrt4!RPC_INTERFACE::DispatchToStubWorker+0x117
00b0fd7c 77c657f0 rpcrt4!RPC_INTERFACE::DispatchToStub+0xa3
00b0fdbc 77c71e34 rpcrt4!RPC_INTERFACE::DispatchToStubWithObject+0xc0
00b0fdfc 77c71bc1 rpcrt4!LRPC_SCALL::DealWithRequestMessage+0x42c
00b0fe20 77c75468 rpcrt4!LRPC_ADDRESS::DealWithLRPCRequest+0x127
00b0ff84 77c5778c rpcrt4!LRPC_ADDRESS::ReceiveLotsaCalls+0x430
00b0ff8c 77c5f7e3 rpcrt4!RecvLotsaCallsWrapper+0xd
00b0ffac 77c5de88 rpcrt4!BaseCachedThreadRoutine+0x9d
00b0ffb8 77e6608b rpcrt4!ThreadStartRoutine+0x1b
00b0ffec 00000000 kernel32!BaseThreadStart+0x34

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Keywords: kbhotfixserver, kbautohotfix, kbexpertiseinter, kbexpertisebeginner, kbqfe, kbsurveynew, KB956770

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Article Info
Article ID : 956770
Revision : 2
Created on : 2/6/2009
Published on : 2/6/2009
Exists online : False
Views : 266