Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

A Windows-based server running that is IIS does not respond to POST requests that have the "Expect: 100-Continue" header


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have Internet Information Services (IIS) 6.0 or IIS 7.0 installed on a server that is running one of the following:
    • Windows Server 2003 SP1 together with hotfix 923507
    • Windows Server 2003 SP2
    • Windows Server 2008
    • Windows Vista SP1
  • IIS clients send POST requests that have the "Expect: 100-continue" header to the server that is running IIS. In the header, the word "continue" contains one or more capital characters, such as a capital "C" in "Continue."
In this scenario, the server that is running IIS does not respond to the "Expect: 100-continue" header. This behavior makes these POST requests that have the "Expect: 100-continue" header time out.

↑ Back to the top


Cause

The Http.sys driver assumes that the "100-continue" letters are lowercase characters. If any capital character (such as a capital "C") exists, the Http.sys driver does not recognize the header and does not respond to the POST request that contains the header.

↑ Back to the top


Resolution

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 Service Pack 1 or Service Pack 2 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 SP1, x86-based version
File nameFile versionFile sizeDateTimePlatform
Http.sys5.2.3790.3188290,30406-Aug-200810:23x86
Windows Server 2003 SP2, x86-based version
File nameFile versionFile sizeDateTimePlatform
Http.sys5.2.3790.4350293,88807-Aug-200811:06x86
Windows Server 2003 SP1, Itanium-based version
File nameFile versionFile sizeDateTimePlatform
Http.sys5.2.3790.3188801,28008-Aug-200806:21IA-64
Windows Server 2003 SP2, Itanium-based version
File nameFile versionFile sizeDateTimePlatform
Http.sys5.2.3790.4350811,00808-Aug-200807:30IA-64
Windows Server 2003 SP2 and Windows XP SP2, x64-based version
File nameFile versionFile sizeDateTimePlatform
Http.sys5.2.3790.4350565,24808-Aug-200807:33x64

Hotfix information for Windows Server 2008 and for Windows Vista

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2008 or Windows Vista Service Pack 1 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information note

The MANIFEST files (.manifest) and MUM files (.mum) installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
Windows Server 2008 and Windows Vista, x86-based version
File nameFile versionFile sizeDateTimePlatform
Http.sys6.0.6001.22240401,40809-Aug-200801:24x86
Windows Server 2008, Itanium-based version
File nameFile versionFile sizeDateTimePlatform
Http.sys6.0.6001.222401,143,80809-Aug-200801:50IA-64
Windows Server 2008 and Windows Vista, x64-based version
File nameFile versionFile sizeDateTimePlatform
Http.sys6.0.6001.22240596,48009-Aug-200802:07x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

Status code "100 Continue"

This interim response is used to inform the client that the initial part of the request was received and has not yet been rejected by the server. The client should continue by sending the remainder of the request or the client should ignore this response if the request has already been completed. The server must send a final response after the request is completed.

For more information about status code definitions, visit the following Web site: For more information in an RFC document, visit the following Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 and for Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Package_for_kb956594_client_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,36709-Aug-200811:51Not Applicable
Package_for_kb956594_client~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,43009-Aug-200811:51Not Applicable
Package_for_kb956594_sc_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42109-Aug-200811:51Not Applicable
Package_for_kb956594_sc~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42209-Aug-200811:51Not Applicable
Package_for_kb956594_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,42509-Aug-200811:51Not Applicable
Package_for_kb956594_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,43009-Aug-200811:51Not Applicable
X86_microsoft-windows-http_31bf3856ad364e35_6.0.6001.22240_none_ad1f5b4a3218f9cd.manifestNot Applicable139,38009-Aug-200804:13Not Applicable
Additional files for all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Ia64_microsoft-windows-http_31bf3856ad364e35_6.0.6001.22240_none_ad20ff40321702c9.manifestNot Applicable139,63409-Aug-200804:51Not Applicable
Package_for_kb956594_sc_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42509-Aug-200811:51Not Applicable
Package_for_kb956594_sc~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42609-Aug-200811:51Not Applicable
Package_for_kb956594_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,42909-Aug-200811:51Not Applicable
Package_for_kb956594_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,43409-Aug-200811:51Not Applicable
Additional files for all supported x64-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Amd64_microsoft-windows-http_31bf3856ad364e35_6.0.6001.22240_none_093df6cdea766b03.manifestNot Applicable139,64409-Aug-200804:52Not Applicable
Package_for_kb956594_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,37509-Aug-200811:51Not Applicable
Package_for_kb956594_client~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43809-Aug-200811:51Not Applicable
Package_for_kb956594_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,42909-Aug-200811:51Not Applicable
Package_for_kb956594_sc~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43009-Aug-200811:51Not Applicable
Package_for_kb956594_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43309-Aug-200811:51Not Applicable
Package_for_kb956594_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43809-Aug-200811:51Not Applicable

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB956594

↑ Back to the top

Article Info
Article ID : 956594
Revision : 3
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 300