Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: The Host Print Service may display an incorrect status for 3270 print sessions when it processes 3270 print jobs for many 3270 print sessions at the same time


View products that this article applies to.

Symptoms

The Microsoft Host Integration Server 2004 Host Print Service (Snaprint.exe) may display an incorrect status for 3270 print sessions when the Host Print service processes 3270 print jobs for many 3270 print sessions at the same time. This is most likely to occur if the Host Print service tries to print to more than 500 print sessions at the same time. The Host Print service may also log the following error message in the application event log:

Event ID: 12
Source: SNA Print Server
Type: Error
Description: The Buffer pool for messages has become exhausted. Data may be lost.

Note This issue also occurs in Microsoft Host Integration Server 2006.

↑ Back to the top


Cause

The Host Print service writes print session status messages to an internal queue. This internal queue can store up to 4.000 status messages. If the print session status messages are written to the queue faster than the messages are processed, the queue may reach its maximum number of entries. If this occurs, the Host Print service will discard the additional status messages and log an event ID 12 error.

↑ Back to the top


Resolution

Service pack information for Host Integration Server 2006

To resolve this problem, obtain the latest service pack for Host Integration Server 2006. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
979497 How to obtain the latest Host Integration Server 2006 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Host Integration Server 2004 Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Snaprint.exe6.0.2429.070,65612-Aug-200802:05x86

↑ Back to the top


More information

After you apply this hotfix, the Host Print service can queue up to 10,000 status messages for active print sessions. The print session status message queue was previously increased from 1,000 to 4,000 entries in Microsoft SNA Server 4.0 SP3. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
225156 Print Server shows incorrect status when starting a large number of printers simultaneously

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB956441, kbqfe, kbexpertiseadvanced, kbhotfixserver, kbautohotfix

↑ Back to the top

Article Info
Article ID : 956441
Revision : 2
Created on : 2/4/2010
Published on : 2/4/2010
Exists online : False
Views : 411