Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

An Outlook Anywhere client continually uses the wrong credentials every time that it tries to authenticate itself on an Exchange server after you install ISA Server 2006 Service Pack 1


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In Microsoft Internet Security and Acceleration (ISA) Server 2006 with Service Pack 1 (SP1), you publish a Microsoft Exchange Server 2003-based server.
  • When you publish the Exchange server, you select the Outlook RPC/HTTP(s) option.
  • On an external computer, a user tries to connect to the Exchange server by using Microsoft Office Outlook.

    Note When an external computer uses Outlook to connect to an Exchange server through RPC, the external computer is called an Outlook Anywhere client.
  • On the Outlook Anywhere client, the user provides the wrong user name or the wrong password.
In this scenario, the Outlook Anywhere client continually uses the wrong credentials every time that it tries to authenticate itself on the Exchange server. The user is not prompted to enter the correct credentials. Additionally, if the Account Lockout policy is implemented in Active Directory, the user account eventually becomes locked out.

↑ Back to the top


Cause

This problem occurs because of an issue in ISA Server 2006 SP1. When wrong credentials are used, ISA Server 2006 should return a 401 response that contains a WWW-Authenticate header. However, ISA Server 2006 incorrectly returns a 502 response.

↑ Back to the top


Resolution

To resolve this problem, apply the hotfix rollup package that is described in the following Microsoft Knowledge Base article:

956269 Description of the ISA Server 2006 hotfix package: July 28, 2008

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: KB956192, kbqfe, kbfix, kbexpertiseadvanced

↑ Back to the top

Article Info
Article ID : 956192
Revision : 1
Created on : 9/9/2008
Published on : 9/9/2008
Exists online : False
Views : 289