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You cannot use a UPN-formatted user name to log on to a Windows Server 2003-based FTP server that is running IIS 6.0 if the domain controller for authentication is running Windows Server 2008


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In an Active Directory domain environment, you have a domain controller that is running Windows Server 2008.
  • In this domain, you have a Windows Server 2003-based member server. This member server has Internet Information Service (IIS) 6.0 installed. Also, you configured the member server to be an FTP server.
  • You try to log on to the FTP server by supplying user name in the User Principal Name (UPN) format (user@domain.com).
In this scenario, you cannot log on to the FTP server.

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Cause

This issue occurs because the Windows Server 2008-baesd domain controller cannot authenticate the user name in UPN format froman FTP server that is running IIS 6.0.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, the computer must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions

File nameFile versionFile sizeDateTimeSP requirementService branch
Lonsint.dll6.0.3790.319013,31213-Aug-200804:54SP1SP1QFE
Lonsint.dll6.0.3790.435313,31213-Aug-200804:49SP2SP2QFE

Windows Server 2003, Itanium-based versions

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Lonsint.dll6.0.3790.319033,28013-Aug-200803:11IA-64SP1SP1QFE
Wlonsint.dll6.0.3790.319013,31213-Aug-200803:11x86SP1SP1QFE\WOW
Lonsint.dll6.0.3790.435333,28013-Aug-200803:17IA-64SP2SP2QFE
Wlonsint.dll6.0.3790.435313,31213-Aug-200803:17x86SP2SP2QFE\WOW

Windows Server 2003, x64-based versions

File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Lonsint.dll6.0.3790.319017,92013-Aug-200803:12x64SP1SP1QFE
Wlonsint.dll6.0.3790.319013,31213-Aug-200803:12x86SP1SP1QFE\WOW
Lonsint.dll6.0.3790.435317,92013-Aug-200803:36x64SP2SP2QFE
Wlonsint.dll6.0.3790.435313,31213-Aug-200803:36x86SP2SP2QFE\WOW

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Workaround

To work around the issue, supply the user name in the traditional "domain\username" format instead of the UPN format.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
243280 Users Can Log On Using User Name or User Principal Name
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, KB956114

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Article Info
Article ID : 956114
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 488