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An ADO-based application may stop responding when it uses the adAsyncExecute option to open a Recordset object in Windows Server 2003 or in Windows XP


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have an application that uses Microsoft ActiveX Data Objects (ADO) to connect to an instance of SQL Server in Windows Server 2003 or in Windows XP.
  • The ADO-based application uses the adAsyncExecute option to open the Recordset object.
In this scenario, the application may stop responding (hang). When you view the thread information in Activity Monitor in SQL Server Management Studio (SSMS), you may find that at least two threads have stopped responding.

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Cause

This problem occurs because of a deadlock between these threads.

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Resolution

Hotfix information

Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Msado15.dll2.82.3193.0598,01618-Aug-200815:01
Odbc32.dll3.526.3193.0245,76018-Aug-200815:01

Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Msado15.dll2.82.4356.0598,01618-Aug-200814:52
Odbc32.dll3.526.4356.0245,76018-Aug-200814:52

Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msado15.dll2.82.3193.01,855,48818-Aug-200813:06IA-64
Odbc32.dll3.526.3193.0720,89618-Aug-200813:06IA-64
Wmsado15.dll2.82.3193.0598,01618-Aug-200813:06x86
Wodbc32.dll3.526.3193.0245,76018-Aug-200813:06x86

Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msado15.dll2.82.4356.01,855,48818-Aug-200813:41IA-64
Odbc32.dll3.526.4356.0720,89618-Aug-200813:41IA-64
Wmsado15.dll2.82.4356.0598,01618-Aug-200813:41x86
Wodbc32.dll3.526.4356.0245,76018-Aug-200813:41x86

Windows Server 2003 with Service Pack 1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msado15.dll2.82.3193.01,019,90418-Aug-200813:06x64
Odbc32.dll3.526.3193.0417,79218-Aug-200813:06x64
Wmsado15.dll2.82.3193.0598,01618-Aug-200813:06x86
Wodbc32.dll3.526.3193.0245,76018-Aug-200813:06x86

Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msado15.dll2.82.4356.01,019,90418-Aug-200813:42x64
Odbc32.dll3.526.4356.0417,79218-Aug-200813:42x64
Wmsado15.dll2.82.4356.0598,01618-Aug-200813:42x86
Wodbc32.dll3.526.4356.0245,76018-Aug-200813:42x86

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows XP Service Pack 2 or a later service pack installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389� How to obtain the latest Windows XP service pack
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Msado15.dll2.81.1139.0536,57619-Aug-200805:56
Odbc32.dll3.525.1139.0249,85619-Aug-200805:56

Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Msado15.dll2.81.3006.0536,57619-Aug-200805:50
Odbc32.dll3.525.3006.0249,85619-Aug-200805:50

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbqfe, kbhotfixserver, KB955843

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Article Info
Article ID : 955843
Revision : 1
Created on : 9/3/2008
Published on : 9/3/2008
Exists online : False
Views : 269