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Your screen flickers when you start WPF applications in a Windows Server 2003 terminal server session


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use a non-administrator user account to connect to a Windows Server 2003-base terminal server by using a third-party terminal client, such as a Citrix ICA client.
  • You run Windows Presentation Foundation (WPF) applications in the terminal server session.
In this scenario, you may notice that your screen flickers. You do not encounter this issue when you use Remote Desktop Connection (RDC) to create the terminal server session.

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Cause

This issue occurs because the non-administrator user account cannot access the %WINDIR%\System32 folder. By default, WPF writes the output file to the %WINDIR%\System32 folder. The %WINDIR%\System32 folder requires administrator permissions. When the non-administrator account tries to access this folder, the WPF caching code is triggered. This code causes the screen to flicker.

In 32-bit versions of the Windows Server 2003 operating system, the output file is D3d9caps.dat. In 64-bit versions of the Windows Server 2003 operating system, the output file is D3d9caps64.dat.

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Resolution

To resolve this problem, install the following hotfix. After you install this hotfix, WPF applications write the output file to the current user profile instead of to the %WINDIR%\System32 folder.

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
D3d8.dll5.3.3790.43361,042,43218-Jul-200808:12x86SP2
D3d9.dll5.3.3790.43361,690,62418-Jul-200808:12x86SP2
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
D3d9.dll5.3.3790.43362,097,66418-Jul-200806:40x64SP2Not Applicable
Wd3d8.dll5.3.3790.43361,042,43218-Jul-200806:40x86SP2WOW
Wd3d9.dll5.3.3790.43361,690,62418-Jul-200806:40x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbqfe, KB955692

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Article Info
Article ID : 955692
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 488