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You cannot connect to an ADAM instance in Windows Server 2003 by using the Secure Sockets Layer 3 protocol together with a certificate that is larger than 1024 bytes


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You are running an Active Directory Application Mode (ADAM) instance on a Windows Server 2003-based computer.
  • You connect to the ADAM instance by using the Secure Sockets Layer (SSL) 3 protocol.
  • The certificate that you use for the SSL 3 protocol is larger than 1024 bytes.
In this scenario, the connection to the ADAM instance resets instead of being established.

Note A connection to a Windows Server 2003 domain controller of the same configuration can be established successfully.

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Cause

This problem occurs because ADAM incorrectly handles the certificate data during the handshake process.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following:
  • Windows Server 2003 R2
  • Active Directory Application Mode Service Pack 1

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Adamdsa.dll1.1.3790.31921,631,23218-Aug-200811:20x86
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Adamdsa.dll1.1.3790.43551,632,76818-Aug-200811:09x86
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Adamdsa.dll1.1.3790.31922,956,80018-Aug-200809:02x64
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Adamdsa.dll1.1.3790.43552,959,87218-Aug-200809:09x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Workaround

To work around this problem, use one of the following methods:
  • Connect to the ADAM instance by using a 1024-byte certificate for the SSL 3 protocol.
  • Connect to the ADAM instance by using a Secure Sockets Layer 2 protocol.

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More information

For more information about the Secure Sockets Layer 3 protocol, visit the following Microsoft Web sites:For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbqfe, KB955610

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Article Info
Article ID : 955610
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 229