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The InitializeSecurityContext function fails with a status of "STATUS_INSUFFICIENT_RESOURCES (0xC000009A)" when the token size of a security principal is greater than 20,000 bytes in Windows Server 2003


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In a Windows Server 2003 environment, the InitializeSecurityContext function is called by a kernel mode component.
  • The token size of an affected security principal is greater than 20,000 bytes.
In this scenario, the InitializeSecurityContext function fails with a status of "STATUS_INSUFFICIENT_RESOURCES (0xC000009A)."

This issue may also cause some other problems. For example, if you try to access a file share resource on a Windows Server 2003-based computer, you may receive the following error message:
Insufficient system resources exist to complete the requested service

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Cause

This problem occurs when Local Security Authority (LSA) allocates some user mode memory that is used to map SecBuffer data back to the caller in kernel mode. However, the calculation to request additional memory is incorrect, and the request may fail if part of the requested memory range is being used.

Note LSA makes the allocation request only if the buffer size is greater than 20,000 bytes.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.3177822,78418-Jul-200815:04x86
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.4337815,61618-Jul-200815:08x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.31772,163,20018-Jul-200812:55IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.43372,165,24821-Jul-200814:43IA-64
Windows Server 2003 with Service Pack 1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.31771,566,72018-Jul-200812:55x64
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.43371,567,23221-Jul-200814:44x64
Windows XP with Service Pack 1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.31771,566,72018-Jul-200812:55x64
Windows XP with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Lsasrv.dll5.2.3790.43371,567,23221-Jul-200814:44x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbqfe, kbhotfixserver, KB955575

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Article Info
Article ID : 955575
Revision : 4
Created on : 8/4/2008
Published on : 8/4/2008
Exists online : False
Views : 331