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SMB functions time out earlier than expected on a Windows 2003-based computer that has multiple processors installed


View products that this article applies to.

Symptoms

When an application uses some Server Message Block (SMB) functions, such as accessing shared files or folders, on a Windows 2003-based computer that has multiple processors installed, the SMB functions time out earlier than expected.

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Cause

This problem occurs because of a race condition in the SMB redirector.

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Resolution

Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have Windows Server 2003 SP1 or Windows Server 2003 SP2 installed.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003 SP1, x86
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.3183438,27230-Jul-200810:00x86
Windows Server 2003 SP2, x86
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.4344438,27230-Jul-200811:39x86
Windows Server 2003 SP1, x64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.3183786,43230-Jul-200813:07x64
Windows Server 2003 SP2, x64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.4344786,94430-Jul-200813:18x64
Windows Server 2003 SP1, IA64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.31831,171,45630-Jul-200813:10IA-64
Windows Server 2003 SP2, IA64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.43441,171,45630-Jul-200813:15IA-64

Windows XP

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
You must have Windows XP x64 version installed.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows XP SP1, x64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.3183786,43230-Jul-200813:07x64
Windows XP SP2, x64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Mrxsmb.sys5.2.3790.4344786,94430-Jul-200813:18x64

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More information

For example, this problem occurs in the following scenario:
  • The client uses an application that connects to a remote computer that is running Windows Server 2003 and SQL Server 2008.
  • The application obtains a handle to a FILESTREAM file. The application may do this by using the OpenSqlFilestream API or the .NET SqlFilestream class.
  • The application writes to the handle. Then, the application closes the handle.
  • The FILESTREAM file belongs to a table that has a potentially long-running update trigger installed. The application postpones the close handle operation until the trigger finishes its execution. However, because of a problem in the SMB protocol, the close handle operation times out earlier.
  • The close handle operation times out. Therefore, the associated SQL Server transaction is invalid. Therefore, the attempt to commit the transaction fails.
For more information about the FILESTREAM feature, visit the following Microsoft Developer Network (MSDN) Web site: For more information, click the following article number to view the article in the Microsoft Knowledge Base:
955535� Server Message Block (SMB) redirector functions time out more quickly than expected on a Windows XP-based computer that has multiple processors installed
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbsurveynew, kbautohotfix, kbhotfixserver, kbqfe, KB955544

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Article Info
Article ID : 955544
Revision : 1
Created on : 1/22/2009
Published on : 1/22/2009
Exists online : False
Views : 267