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All snapshots may be deleted unexpectedly in Windows Server 2003 and in Windows XP Professional x64 Edition when the snapshot protection mode is enabled, and the system is under memory stress


View products that this article applies to.

Symptoms

Consider the following scenario. In Windows Server 2003 or in Windows XP Professional x64 Edition, you configure the Shadow Copy feature on a volume to store the diff area on a dynamic volume. Additionally, the snapshot protection mode is enabled on the computer.

If the size of the diff area on the dynamic volume is larger than the size of the physical memory plus the size of all page files, all the snapshots may be deleted unexpectedly. When this problem occurs, the snapshot files still exist in the System Volume Information folder on the dynamic volume. However, these files are useless.

Additionally, the following events are logged in the System log:
  • Event Type: Error
    Event Source: VolSnap
    Event Category: None
    Event ID: 6
    User: N/A
    Computer: <ComputerName>
    Description:
    The shadow copy of volume <name> could not create a new paged heap. The system may be low on virtual memory.

  • Event Type: Error
    Event Source: VolSnap
    Event Category: None
    Event ID: 83
    User: N/A Computer: <ComputerName>
    Description:
    Volume <name> is offline for shadow copy protection. A memory allocation failed. Please try clearing the protection fault or restart the computer. If all else fails, revert out of shadow copy protection mode to reclaim the use of the volume while losing the shadow copies.

  • Event Type: Error
    Event Source: VolSnap
    Event Category: None
    Event ID: 84
    User: N/A
    Computer: <ComputerName>
    Description:
    Volume <name> is offline for shadow copy protection. A memory mapping failed. Consider increasing the size of the page file. Please try clearing the protection fault or restart the computer. If all else fails, revert out of shadow copy protection mode to reclaim the use of the volume while losing the shadow copies.

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Cause

When the size of the diff area on a volume grows to be very large, the Volsnap.sys driver consumes much memory. If the size of the diff area is larger than the size of the physical memory plus the size of all page files, snapshot protection faults occur when you restart the computer. Additionally, snapshot protection faults bring the volume offline. All the snapshots are deleted because dynamic disks in Windows Server 2003 do not support the volume offline operation and the volume online operation. This problem occurs even if you increase the size of page files, and you restart the computer the second time.

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Resolution

Resolution for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.3277152,06408-Jan-200911:24x86
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.3277246,78408-Jan-200904:40x64
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.3277541,69608-Jan-200904:39IA-64
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.4442152,06408-Jan-200914:29x86
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.4442246,78408-Jan-200904:46x64
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.4442541,69608-Jan-200904:44IA-64

Resolution for Windows XP Professional x64 Edition

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows XP Professional x64 Edition or Windows XP Professional x64 Edition Service Pack 2 on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Professional x64 Edition
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.3277246,78408-Jan-200904:40x64
Windows XP Professional x64 Edition with Service Pack 2
File nameFile versionFile sizeDateTimePlatform
Dmio.sys5.2.3790.4442246,78408-Jan-200904:46x64

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Workaround

To work around the issue, increase the size of physical memory or the size of page files before this problem occurs. However, it is difficult to predict the appropriate size.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base: -
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseadvanced, kbfix, kbautohotfix, kbsurveynew, kbqfe, KB955543

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Article Info
Article ID : 955543
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 287