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The print process crashes under heavy stress on a computer that is running Windows Server 2003 or Windows XP Professional x64 Edition if the computer uses hyper-threading technology


View products that this article applies to.

Symptoms

You have a computer that uses the hyper-threading technology. Additionally, the computer is running Windows Server 2003 or Windows XP Professional x64 Edition. When you print on the computer, the print process crashes under heavy stress.

Note This problem occurs mainly on multiprocessor computers and on multicore computers.

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Cause

This problem occurs because of a race condition in the Spooler service.

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Resolution

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 Service Pack 1, Windows Server 2003 Service Pack 2, Windows XP Professional x64 Edition, or Windows XP Professional x64 Edition Service Pack 2 on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.3176349,69617-Jul-200815:18x86
Windows Server 2003 with Service Pack 1, x64-based versions, and Windows XP Professional x64 Edition
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.3176751,61617-Jul-200813:12x64
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.3176971,26417-Jul-200813:11IA-64
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4336343,04017-Jul-200815:22x86
Windows Server 2003 with Service Pack 2, x64-based versions, and Windows XP Professional x64 Edition with Service Pack 2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4336751,10417-Jul-200813:17x64
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4336971,77617-Jul-200813:15IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

This problem also occurs in Windows Vista and in Windows Server 2008. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
955806� The print process crashes under heavy stress on Windows Vista-based or Windows Server 2008-based computers
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base: -
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbwinserv2003postsp2fix, kbexpertiseadvanced, kbfix, kbautohotfix, kbsurveynew, kbqfe, KB955455

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Article Info
Article ID : 955455
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 319