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The Wmiprvse.exe process crashes when an application runs a query to enumerate process information on a Windows Server 2003 R2-based computer that has Subsystem for UNIX-based Applications installed


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have Subsystem for UNIX-based Applications (SUA) installed on a Windows Server 2003 R2-based computer.
  • An application runs a query to enumerate process information.
However, the Wmiprvse.exe process crashes. For example, this problem occurs when you use the Tasklist.exe tool to display process information. In this scenario, you receive the following error message:
The remote procedure call failed

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Cause

This problem occurs because the command-line buffer in the RTL_USER_PROCESS_PARAMETERS structure is of the Character type in UNIX-based processes. However, in most other processes, that command-line buffer is of the Wide-Character type. Windows Management Instrumentation (WMI) assumes that the value of the MaximumLength property that is used for copying data into the command-line buffer is an even number, even if the value of this property is an odd number. Therefore, heap corruption occurs in the memory pool from which the command-line buffer is allocated.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2003 R2.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Notes
  • If you are running Windows Server 2003 R2 with Service Pack 1, select the hotfix package that has the file name "Fix337353."
  • If you are running Windows Server 2003 R2 with Service Pack 2, select the hotfix package that has the file name "Fix233584."
Windows Server 2003 R2 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Psxdll.dll9.0.3790.3499248,83206-Aug-201021:18x86SP1
Psxss.exe9.0.3790.3499570,88002-Aug-201021:58x86SP1
Windows Server 2003 R2 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Psxdll.dll9.0.3790.4330248,83209-Jul-200814:24x86SP2
Psxss.exe9.0.3790.4330571,39209-Jul-200810:40x86SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbqfe, KB955454

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Article Info
Article ID : 955454
Revision : 3
Created on : 11/30/2010
Published on : 11/30/2010
Exists online : False
Views : 308