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Event 4106 generated by a Windows Server 2008-based Terminal licensing server may report incorrect number of issued "Per User" licenses


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install the "TS Licensing tools" feature on a Windows Server 2008-based server.
  • Some "Per User" licenses are installed on this Terminal Licensing server.
  • You create a "Per User CAL usage" report in the TS Licensing Manager tool.
In this scenario, the following event is logged in the System log on the server:

Log Name: System
Source: Microsoft-Windows-TerminalServices-Licensing
Date: date & time
Event ID: 4106
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: computer name Description: TS CAL reporting: Windows Server 2008 PerUser CALs: Installed: number, Issued: 0

However, this event incorrectly reports that the number of issued licenses is 0. This incorrect information makes it difficult for customers to track the licenses.

Note The "Per User CAL usage" report returns the correct number of issued licenses.

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Cause

The TS Licensing Manager tool does not generate the correct number of licenses that have been issued by the Terminal licensing server.

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Resolution

A hotfix is available to resolve this issue.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, the computer must run Windows Server 2008.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista and Windows Server 2008 file information notes

The MANIFEST files (.manifest) and MUM files (.mum) installed for each environment are listed separately . MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Lserver.dll6.0.6001.22283468,99209-Oct-200804:03x86
Tlsmigplugin.dll6.0.6001.2228375,77609-Oct-200804:03x86
Tlsunattend.exe6.0.6001.222838,70409-Oct-200804:02x86
Tslicensing.events.xmlNot Applicable54918-Dec-200721:02Not Applicable
For all supported x64-based versions of Windows Server 2008 and Windows Vista
File nameFile versionFile sizeDateTimePlatform
Lserver.dll6.0.6001.22283642,04809-Oct-200805:33x64
Tlsmigplugin.dll6.0.6001.22283102,91209-Oct-200805:33x64
Tlsunattend.exe6.0.6001.2228310,24009-Oct-200805:33x64
Tslicensing.events.xmlNot Applicable54918-Dec-200721:02Not Applicable

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about Event 4106, visit the following Microsoft Web site: For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008 and Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and Windows Vista
File namePackage_1_for_kb955425~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,797
Date (UTC)10-Oct-2008
Time (UTC)21:12
PlatformNot Applicable
File namePackage_for_kb955425_server_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,419
Date (UTC)10-Oct-2008
Time (UTC)21:12
PlatformNot Applicable
File namePackage_for_kb955425_server~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)10-Oct-2008
Time (UTC)21:12
PlatformNot Applicable
File nameX86_416493feef6bae45d8722ca511bc5de7_31bf3856ad364e35_6.0.6001.22283_none_707be8105eefcf15.manifest
File versionNot Applicable
File size718
Date (UTC)10-Oct-2008
Time (UTC)21:12
PlatformNot Applicable
File nameX86_microsoft-windows-t..vices-licenseserver_31bf3856ad364e35_6.0.6001.22283_none_a17e00fcb7e40545.manifest
File versionNot Applicable
File size97,884
Date (UTC)09-Oct-2008
Time (UTC)04:31
PlatformNot Applicable
Additional files for all supported x64-based versions of Windows Server 2008 and Windows Vista
File nameAmd64_987a4893f6959252eff988907a2a7ec4_31bf3856ad364e35_6.0.6001.22283_none_0327733add042eef.manifest
File versionNot Applicable
File size722
Date (UTC)10-Oct-2008
Time (UTC)21:12
PlatformNot Applicable
File nameAmd64_microsoft-windows-t..vices-licenseserver_31bf3856ad364e35_6.0.6001.22283_none_fd9c9c807041767b.manifest
File versionNot Applicable
File size97,940
Date (UTC)09-Oct-2008
Time (UTC)06:13
PlatformNot Applicable
File namePackage_1_for_kb955425~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,807
Date (UTC)10-Oct-2008
Time (UTC)21:12
PlatformNot Applicable
File namePackage_for_kb955425_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,427
Date (UTC)10-Oct-2008
Time (UTC)21:12
PlatformNot Applicable
File namePackage_for_kb955425_server~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)10-Oct-2008
Time (UTC)21:12
PlatformNot Applicable

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbqfe, kbhotfixserver, KB955425

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Article Info
Article ID : 955425
Revision : 1
Created on : 11/11/2008
Published on : 11/11/2008
Exists online : False
Views : 370