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A malformed thread-topic field is shown if a message is sent from a mobile device that is using Exchange ActiveSync


View products that this article applies to.

Symptoms

When Microsoft Exchange Server 2003 users send a message from a mobile device that is using Exchange ActiveSync, the thread-topic field is not encoded as defined in RFC 1522 if the subject includes non-ASCII characters.

Instead, the thread-topic field is just a copy from the original characters of the subject. When such a message is sent to an external mail system, it may be rejected or misunderstood. For example, if the original subject is "Test �crou," the external recipients obtain the message that includes the following field:
Thread-Topic: Test �crou 16h15 ...... Subject: =?iso-8859-1?Q?Test_=E9crou_16h15?=
Note This issue does not occur if you send the same message from Microsoft Office Outlook or from Outlook Web Access.

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Cause

The term "thread-topic" indicates the topic of a conversation thread. It is not a required MIME field in RFC 2822. It is only an optional MIME field in RFC 2822. In this scenario, Exchange Server 2003 does not include the thread-topic field as a default MIME header and encodes it.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Microsoft Exchange Server 2003 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

This hotfix requires Exchange Server 2003 Service Pack 2 to be installed on the server because of file dependencies.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, the following services are restarted automatically when you apply this hotfix:
  • The Microsoft Exchange Information Store service
  • The Internet Information Services (IIS) Admin Service and all dependent services

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Exmime.dll6.5.7654.5201,72819-Aug-200818:25

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More information

For more information about thread-topic field, visit the following Web site:For more information about RFC 1522, visit the following Web site: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

Visit our Windows Phone Forums for more helpful hints and ideas.

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Keywords: kbautohotfix, kbexchmobility, kbexpertiseinter, kbsurveynew, kbhotfixserver, kbqfe, KB954727

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Article Info
Article ID : 954727
Revision : 2
Created on : 5/3/2010
Published on : 5/3/2010
Exists online : False
Views : 310