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The SMS_EXECUTIVE service of System Center Configuration Manager 2007 on a child site server may crash when it handles the .sha file and sends inventory data to its parent site


View products that this article applies to.

Symptoms

Consider the following scenario:
  • A SiteCode.sha file is generated under the Dataldr.box folder when a child site is first assigned to a parent site or the parent site is changed in System Center Configuration Manager 2007 Service Pack 1 (SP1).
  • The SMS_EXECUTIVE service on the child site sends inventory data to the parent site when it handles the SiteCode.sha file.
In this scenario, the SMS_EXECUTIVE service may crash. The issue most likely occurs when the pageheap or gflags option is enabled.

Additionally, the following event is logged in the System log on the child site server:
Source: Service Control Manager Date:  Date & Time 
Event ID: 7034 Task Category: None Level: Error Keywords: Classic User: N/A Computer: Computer Name
Description: The SMS_EXECUTIVE service terminated unexpectedly. It has done this 1 time(s).

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Cause

This problem occurs because of an issue in the inventory data loader component.

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Resolution

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft System Center Configuration Manager 2007, available from this Microsoft web site: http://www.microsoft.com/download/details.aspx?FamilyID=3318741a-c038-4ab1-852a-e9c13f8a8140
For a list of issues resolved in this service pack, click on the following article number in the Microsoft Knowledgebase:
971348 List of hotfixes and updates that are contained in System Center Configuration Manager 2007 Service Pack 2

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have System Center Configuration Manager 2007 Service Pack 1 installed to apply this hotfix. To resolve this issue, install hotfix 954716 on System Center Configuration Manager 2007 Service Pack 1 child site servers.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Baseobj.dll4.0.6221.1103991,16030-Nov-200819:10

Note This file attribute information applies to x86 platform, x64 platform, International Client Pack 1 and International Client Pack 2.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbhotfixserver, kbqfe, kbpubtypekc, kbprb, kb, kbbug

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Article Info
Article ID : 954716
Revision : 2
Created on : 4/9/2020
Published on : 4/9/2020
Exists online : False
Views : 519