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FIX: If the requested file already exists on the local IIS proxy server, a request is rejected, or the performance is decreased in IIS 7.0


View products that this article applies to.

Symptoms

In Internet Information Services (IIS) 7.0, request routing modules such as Microsoft Application Request Routing can transform the server that is running IIS into a proxy server. In this case, the IIS proxy server can forward requests to other destinations. However, a request is rejected if the following conditions are true:
  • The requested file already exists on the local IIS proxy server.
  • The system access control list (SACL) of the requested file does not give the access permission to the user who makes the request.
Additionally, the performance is decreased if the following conditions are true:
  • The requested file already exists on the local IIS proxy server.
  • The system access control list (SACL) of the requested file gives the access permission to the user who makes the request.
Note The performance is decreased even if the requested file does not exist on the IIS proxy server.

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Cause

This problem occurs because the requests are first checked locally on the IIS proxy server before the requests are forwarded. However, this operation is unnecessary and decreases the performance.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

You must have Windows Vista Service Pack 1 or Windows Server 2008 installed to apply this hotfix.

Restart requirement

You must restart IIS 7.0 after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
IIS 7.0, x86 version
File nameFile versionFile sizeDateTimePlatform
Iisetw.dll7.0.6001.2220412,28817-Jun-200803:21x86
Iisfreb.dll7.0.6001.22204140,28817-Jun-200803:21x86
Hwebcore.dll7.0.6001.2220412,80017-Jun-200803:21x86
Iiscore.dll7.0.6001.22204189,95217-Jun-200803:21x86
W3dt.dll7.0.6001.2220423,55217-Jun-200803:25x86
IIS 7.0, x64 version
File nameFile versionFile sizeDateTimePlatform
Iisetw.dll7.0.6001.2220414,33617-Jun-200803:47x64
Iisfreb.dll7.0.6001.22204146,94417-Jun-200803:47x64
Hwebcore.dll7.0.6001.2220415,36017-Jun-200803:47x64
Iiscore.dll7.0.6001.22204293,88817-Jun-200803:47x64
W3dt.dll7.0.6001.2220430,72017-Jun-200803:51x64
IIS 7.0, IA-64 version
File nameFile versionFile sizeDateTimePlatform
Iisetw.dll7.0.6001.2220432,76817-Jun-200803:35IA-64
Iisfreb.dll7.0.6001.22204225,79217-Jun-200803:35IA-64
Hwebcore.dll7.0.6001.2220437,37617-Jun-200803:35IA-64
Iiscore.dll7.0.6001.22204541,18417-Jun-200803:35IA-64
W3dt.dll7.0.6001.2220451,71217-Jun-200803:41IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about Application Request Routing, visit the following Microsoft Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbfix, kbhotfixserver, kbautohotfix, kbexpertiseadvanced, kbqfe, KB954438

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Article Info
Article ID : 954438
Revision : 2
Created on : 9/18/2008
Published on : 9/18/2008
Exists online : False
Views : 382