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FIX: A non-variant product is displayed in the cart as Out Of Stock when you add a non-variant product to the cart after you add a variant product in Commerce Server 2007


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use a virtual catalog to display products on the Web site in Microsoft Commerce Server 2007.
  • You do not directly assign an inventory catalog to the virtual catalog.
  • You add a variant product to the cart, and then add a non-variant product to the cart.
In this scenario, the non-variant product is displayed in the cart as Out Of Stock even though there is lots of inventory for that product.

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Cause

This problem occurs because the stored procedure that is used to perform the inventory check does not reset itself after the first product is added to the shopping cart.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Commerce Server 2007 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Inventorycreate.sqlNot applicable193,84616-Jun-200815:57x86
Inv_checkinventory.sqlNot applicable26,52916-Jun-200803:08Not applicable
Inv_updateinventory.sqlNot applicable27,51716-Jun-200803:08Not applicable

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More information

This hotfix updates the stored procedure creation scripts for a new site. For an existing site, you must manually run the Inv_CheckInventory.sql and Inv_UpdateInventory.sql files that are included in the update. Run these files against the product catalog database to update the stored procedures in the database.

Note The only file that is included in this hotfix package is the Inventoryprocedures.pre.sql file. After you apply this hotfix, the Inventoryprocedures.pre.sql file will automatically update the default stored procedure creation script for the newly created product catalog database. To update all the existing stored procedures, you must manually run the inv_CheckInventory.sql and inv_UpdateInventory.sql files that are outside the hotfix package in every SiteName_productcatalog database.

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Keywords: KB954161, kbqfe, kbexpertiseadvanced, kbautohotfix, kbhotfixserver

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Article Info
Article ID : 954161
Revision : 1
Created on : 8/6/2008
Published on : 8/6/2008
Exists online : False
Views : 331