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Call-forwarding function requests from TAPI 2.x clients fail with a "LINEERR_INVALIDPARAM" error on a Windows Server 2003-based telephony server


View products that this article applies to.

Symptoms

Consider the following scenario:
  • In a network environment, a Windows Server 2003-based computer acts as a telephony server.
  • An application uses TAPI 2.x to implement the call-forwarding function.
  • The call-forwarding request is issued from a client computer that is running Windows XP or Windows Vista.
In this scenario, the call-forwarding function fails, and error code LINEERR_INVALIDPARAM is returned. Therefore, users cannot use the call-forwarding functionality.

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Cause

This issue occurs because the TAPI version-checking method on the client side differs from the TAPI version-checking method on the server side. This mismatch causes the function to fail.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 2 (SP2) installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Tapisrv.dll5.2.3790.4347254,97604-Aug-200814:20x86
Windows Server 2003 SP2 and Windows XP SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Tapisrv.dll5.2.3790.4347407,55204-Aug-200812:10x64SP2Not Applicable
Wtapisrv.dll5.2.3790.4347254,97604-Aug-200812:10x86SP2WOW
Windows Server 2003 SP2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Tapisrv.dll5.2.3790.4347697,34404-Aug-200812:04IA-64SP2Not Applicable
Wtapisrv.dll5.2.3790.4347254,97604-Aug-200812:04x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbqfe, kbhotfixserver, KB954057

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Article Info
Article ID : 954057
Revision : 1
Created on : 8/7/2008
Published on : 8/7/2008
Exists online : False
Views : 311