Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Exchange Server Outlook Anywhere feature does not work correctly if it is installed on a Windows Server 2008-based server that has Terminal Services Gateway installed


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Windows Server 2008-based server.
  • This server has Terminal Services Gateway (TS Gateway) and the Microsoft Exchange Server Outlook Anywhere feature installed.
In this scenario, one of the following symptoms occurs:
  • Users cannot connect to Exchange Server by using the RPC-over-HTTP protocol. This symptom occurs if you install the Outlook Anywhere feature before you install Terminal Services Gateway.
  • The Outlook Anywhere feature works correctly after you install Terminal Services Gateway. However, after you open the TS Gateway Manager snap-in, users cannot connect to Exchange Server by using the RPC-over-HTTP protocol. This symptom occurs if you install Terminal Services Gateway before you install the Outlook Anywhere feature.
Note Terminal Services Gateway and the Outlook Anywhere feature both rely on the RPC-over-HTTP protocol.

↑ Back to the top


Cause

This problem occurs because the Basic Authentication setting is disabled when TS Gateway is installed and when you open the TS Gateway Manager snap-in. Outlook Anywhere authentication supports Basic authentication and NTLM authentication. If NTLM authentication is also disabled, Outlook Anywhere cannot function correctly. For example, this problem occurs in Windows Small Business Server 2008 where NTLM authentication is disabled by default.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Msil_aagmmc_31bf3856ad364e35_6.0.6001.22199_none_87b7a8bf7405ebba.manifestNot Applicable4,06810-Jun-200804:53Not Applicable
Package_1_for_kb954034~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,75410-Jun-200820:11Not Applicable
Package_for_kb954034_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,41710-Jun-200820:11Not Applicable
Package_for_kb954034_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,43010-Jun-200820:11Not Applicable
X86_5b37a5ee69544ff69a4c77e535790c36_31bf3856ad364e35_6.0.6001.22199_none_fc83dc279163d2a3.manifestNot Applicable67710-Jun-200820:11Not Applicable
Aagmmc.dll6.0.6001.221991,155,07210-Jun-200803:43x86
Windows Server 2008, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_5b37a5ee69544ff69a4c77e535790c36_31bf3856ad364e35_6.0.6001.22199_none_58a277ab49c143d9.manifestNot Applicable67910-Jun-200820:11Not Applicable
Msil_aagmmc_31bf3856ad364e35_6.0.6001.22199_none_87b7a8bf7405ebba.manifestNot Applicable5,67710-Jun-200806:11Not Applicable
Package_1_for_kb954034~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,76210-Jun-200820:11Not Applicable
Package_for_kb954034_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,42510-Jun-200820:11Not Applicable
Package_for_kb954034_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,43810-Jun-200820:11Not Applicable
Aagmmc.dll6.0.6001.221991,155,07210-Jun-200804:12x86

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbbug, kbfix, kbhotfixserver, kbqfe, KB954034

↑ Back to the top

Article Info
Article ID : 954034
Revision : 2
Created on : 7/22/2008
Published on : 7/22/2008
Exists online : False
Views : 497