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A mailbox server becomes intermittently unresponsive for one or more storage groups, and event ID 623 is logged in Exchange Server 2003


View products that this article applies to.

Symptoms

A Microsoft Exchange Server 2003 mailbox server becomes intermittently unresponsive for one or more storage groups. During these times, users who have a mailbox on the affected storage groups cannot access their mailbox.

Additionally, the following event is logged in the Application log:

Event ID : 623
Raw Event ID : 623
Category : Transaction Manager
Source : ESE
Type : Error
Message : Information Store (process ID) storage group (server name): The version store for this instance (name) has reached its maximum size of xxxMb. It is likely that a long-running transaction is preventing cleanup of the version store and causing it to build up in size. Updates will be rejected until the long-running transaction has been completely committed or rolled back.
Possible long-running transaction:

SessionId:ID
Session-context: value
Session-context ThreadId: thread ID
Cleanup: 1

For more information, click http://www.microsoft.com/contentredirect.asp.

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Cause

This problem occurs because of a design limitation that causes a "version store out of memory" error. This error occurs when the Exchange Server server performs an Active Directory directory service query but does not receive an expected response.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, you must have Microsoft Exchange Server 2003 Service Pack 2 installed.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

However, the following services are stopped and then restarted automatically when you apply this hotfix:
  • The Microsoft Exchange Information Store service
  • The Microsoft Search service
  • The Internet Information Services (IIS) Admin Service and all dependent services

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Cdo.dll6.5.7654.2722,43217-Jul-200816:35
Cdoex.dll6.5.7654.23,959,80817-Jul-200818:18
Davex.dll6.5.7654.21,135,61617-Jul-200818:13
Excdo.dll6.5.7654.23,643,90417-Jul-200818:18
Exoledb.dll6.5.7654.22,620,41617-Jul-200803:13
Exosal.dll6.5.7654.270,14417-Jul-200817:52
Lsmexhc.dll6.5.7654.2142,33617-Jul-200816:37
Madfb.dll6.5.7654.2525,82417-Jul-200818:18
Mdbmsg.dll6.5.7654.23,381,24817-Jul-200817:01
Rtdsmcal.dll6.5.7654.239,93617-Jul-200817:00
Store.exe6.5.7654.25,266,94417-Jul-200817:55

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

When this issue occurs, the following stack trace is generated:
0:185> kL 100
ChildEBP RetAddr  
6180e288 7c822124 ntdll!KiFastSystemCallRet
6180e28c 77e6bad8 ntdll!NtWaitForSingleObject+0xc
6180e2fc 77c61c44 kernel32!WaitForSingleObjectEx+0xac
6180e318 77c61bfa rpcrt4!UTIL_WaitForSyncIO+0x20
6180e33c 77c59f39 rpcrt4!UTIL_GetOverlappedResultEx+0x1d
6180e364 77c5edd5 rpcrt4!CO_SyncRecv+0x71
6180e38c 77c631f8 rpcrt4!OSF_CCONNECTION::TransSendReceive+0xb8
6180e414 77c62f80 rpcrt4!OSF_CCONNECTION::SendFragment+0x2ae
6180e46c 77c62ff3 rpcrt4!OSF_CCALL::SendNextFragment+0x1e2
6180e4c4 77c630c8 rpcrt4!OSF_CCALL::FastSendReceive+0x144
6180e4e0 77c63161 rpcrt4!OSF_CCALL::SendReceiveHelper+0x5b
6180e510 77c713ca rpcrt4!OSF_CCALL::SendReceive+0x41
6180e51c 77c72c8d rpcrt4!I_RpcSendReceive+0x24
6180e530 77ce219b rpcrt4!NdrSendReceive+0x2b
6180e918 77f60a16 rpcrt4!NdrClientCall2+0x22e
6180e930 77f60bd5 advapi32!LsarLookupSids2+0x1c
6180e9b0 77f60a63 advapi32!LsaICLookupSids+0xc1
6180e9f0 77f60d77 advapi32!LsaLookupSids+0x41
6180ea58 77f60cf8 advapi32!LookupAccountSidInternal+0x8b
6180ea80 62c32a56 advapi32!LookupAccountSidW+0x21
6180eab4 004e8039 exosal!I_LookupAccountSidW+0x67
6180ef04 004e7fc8 store!EcNtUserNameFromSid+0x55
6180ef14 00455e50 store!LOGON::WszNTUserName+0x22
6180ef88 0045353d store!LOGON::EcUpdateMailboxTable+0x362
6180f1ec 004562ba store!LOGON::EcConfig+0x16fa
6180f340 004d8152 store!EcDoPrivateLogonOp+0x123
6180f558 0043bebf store!EcLogon+0x3be
6180f7f4 0043bac2 store!EcRpc+0x5bc
6180f870 0043c91c store!EcRpcExt+0x196
6180f8a8 0043c892 store!EcRpcExt2+0x45
6180f904 77c70f4b store!EcDoRpcExt2+0x93
6180f944 77ce23f7 rpcrt4!Invoke+0x30
6180fd44 77ce26ed rpcrt4!NdrStubCall2+0x299
6180fd60 77c709ce rpcrt4!NdrServerCall2+0x19
6180fd94 77c7094f rpcrt4!DispatchToStubInCNoAvrf+0x38
6180fde8 77c70875 rpcrt4!RPC_INTERFACE::DispatchToStubWorker+0x117
6180fe0c 77c612e0 rpcrt4!RPC_INTERFACE::DispatchToStub+0xa3
6180fe40 77c610b9 rpcrt4!OSF_SCALL::DispatchHelper+0x149
6180fe54 77c61199 rpcrt4!OSF_SCALL::DispatchRPCCall+0x10d
6180fe84 77c61031 rpcrt4!OSF_SCALL::ProcessReceivedPDU+0x57f
6180fea4 77c609f9 rpcrt4!OSF_SCALL::BeginRpcCall+0x194
6180ff04 77c60a3a rpcrt4!OSF_SCONNECTION::ProcessReceiveComplete+0x435
6180ff18 77c606eb rpcrt4!ProcessConnectionServerReceivedEvent+0x21
6180ff84 77c5f9f7 rpcrt4!LOADABLE_TRANSPORT::ProcessIOEvents+0x1b8
6180ff8c 77c5f7e3 rpcrt4!ProcessIOEventsWrapper+0xd
6180ffac 77c5de88 rpcrt4!BaseCachedThreadRoutine+0x9d
6180ffb8 77e6608b rpcrt4!ThreadStartRoutine+0x1b
6180ffec 00000000 kernel32!BaseThreadStart+0x34

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Keywords: KB953952, kbqfe, kbhotfixserver, kbautohotfix, kbexpertiseadvanced, kbexchstore

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Article Info
Article ID : 953952
Revision : 1
Created on : 8/1/2008
Published on : 8/1/2008
Exists online : False
Views : 260