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Message after multiple unsuccessful calls to certain functions on a computer that is running Windows Server 2003 or Windows XP Professional x64 Edition: "Running out of physical memory"


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2003 or Windows XP Professional x64 Edition, the operating system may become unstable after applications or services perform multiple unsuccessful calls to the following functions:
  • HalAllocateCommonBuffer
  • MmAllocateContiguousMemory
  • MmAllocateContiguousMemorySpecifyCache
If you check memory usage by using a live debugging program or a captured dump file, you may see the following message logged when this issue occurs:
Running out of physical memory

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Cause

When Memory Manager cannot locate any contiguous memory blocks, memory allocation operations fail. However, Memory Manager does not release the global index that keeps track of the number of memory allocation operations when these operations fail. Therefore, the "Resident available pages" number becomes very low after multiple unsuccessful memory allocation attempts.

Note In this scenario, Memory Manager does not indicate the actual volume of available memory.

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Resolution

Hotfix information for Windows Server 2003

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows Server 2003 Service Pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 with Service Pack 1 (SP1) or Windows Server 2003 with Service Pack 2 (SP2) installed.
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntkrnlmp.exe5.2.3790.31462,466,30427-May-200811:59Not ApplicableSP1
Ntkrnlpa.exe5.2.3790.31462,279,42427-May-200811:07x86SP1
Ntkrpamp.exe5.2.3790.31462,319,36027-May-200811:08Not ApplicableSP1
Ntoskrnl.exe5.2.3790.31462,426,36827-May-200811:58x86SP1
Windows Server 2003 with Service Pack 2, x86 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Ntkrnlmp.exe5.2.3790.43012,496,00027-May-200811:02Not ApplicableSP2
Ntkrnlpa.exe5.2.3790.43012,307,58427-May-200810:00x86SP2
Ntkrpamp.exe5.2.3790.43012,348,54427-May-200812:36Not ApplicableSP2
Ntoskrnl.exe5.2.3790.43012,455,55227-May-200811:02x86SP2
Windows Server 2003, x64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.3146280,06427-May-200812:33x64SP1
Ntkrnlmp.exe5.2.3790.31464,646,40027-May-200812:33x64SP1
Ntoskrnl.exe5.2.3790.31464,503,04027-May-200812:33x64SP1
Windows Server 2003 with Service Pack 2, x64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.4301280,06427-May-200812:40x64SP2
Ntkrnlmp.exe5.2.3790.43014,604,41627-May-200812:40x64SP2
Ntoskrnl.exe5.2.3790.43014,534,27227-May-200812:40x64SP2
Windows Server 2003 with Service Pack 1, IA-64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.31461,636,35227-May-200812:33IA-64SP1Not Applicable
Ntkrnlmp.exe5.2.3790.31466,534,14427-May-200812:33IA-64SP1Not Applicable
Wntdll.dll5.2.3790.3146765,95227-May-200812:33x86SP1WOW
Windows Server 2003 with Service Pack 2, IA-64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ntdll.dll5.2.3790.43011,636,86427-May-200812:39IA-64SP2Not Applicable
Ntkrnlmp.exe5.2.3790.43016,568,96027-May-200812:39IA-64SP2Not Applicable
Wntdll.dll5.2.3790.4301766,46427-May-200812:39x86SP2WOW

Hotfix information for Windows XP

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Windows XP service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Windows XP Professional x64 Edition with SP1 or Windows XP Professional x64 Edition with SP2 installed.
322389 � How to obtain the latest Windows XP service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Professional x64 Edition with SP1, x64 Edition
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.3146280,06427-May-200812:33x64SP1
Ntkrnlmp.exe5.2.3790.31464,646,40027-May-200812:33x64SP1
Ntoskrnl.exe5.2.3790.31464,503,04027-May-200812:33x64SP1
Windows XP Professional x64 Edition with SP2, x64 version
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Hal.dll5.2.3790.4301280,06427-May-200812:40x64SP2
Ntkrnlmp.exe5.2.3790.43014,604,41627-May-200812:40x64SP2
Ntoskrnl.exe5.2.3790.43014,534,27227-May-200812:40x64SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbexpertiseinter, kbhotfixserver, kbqfe, KB953600

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Article Info
Article ID : 953600
Revision : 1
Created on : 6/11/2008
Published on : 6/11/2008
Exists online : False
Views : 460