Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you remove a third-party disk resource from a Cluster group by using the Failover Cluster Management Microsoft Management Console (MMC) snap-in: "Failure removing storage resource. Could not move the resource to available stora...


View products that this article applies to.

Symptoms

On a computer that is running Windows Server 2008, you use the Failover Cluster Management snap-in in Microsoft Management Console (MMC) to remove a third-party disk resource. However, you receive the following error message:
Failure removing storage resource. Could not move the resource to available storage.

After you receive this error message, the Assertion Failed dialog box appears and you have the following options:
  • Abort
  • Retry
  • Ignore


Even though you receive the error message, the third-party disk resource is moved successfully to the Available Storage group.

You may also encounter this issue when you remove Volume Manager Disk Group disk resources created by Symantec Storage Foundation.

↑ Back to the top


Cause

This issue occurs because the Failover Cluster Management MMC snap-in performs an assert check when you perform the remove operation. The error message appears if storage resources that are removed are not physical disks.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problemP1 that P2 described in this article. Apply this hotfix only to systems that are experiencing the problemP1 described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2
  • The Failover Clustering feature is enabled

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel. The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately. MUM and MANIFEST files, and the associated security catalog (.cat) files, are critical to maintaining the state of the updated component. The security catalog files (attributes not listed) are signed with a Microsoft digital signature.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Failoverclusters.objectmodel.dll6.0.6001.22431503,29612-May-200917:42x86
For all supported x86-based versions of Windows Server 2008 SP2
File nameFile versionFile sizeDateTimePlatform
Failoverclusters.objectmodel.dll6.0.6002.22134503,29612-May-200916:56x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Failoverclusters.objectmodel.dll6.0.6001.22431509,44012-May-200917:48x64
For all supported x64-based versions of Windows Server 2008 SP2
File nameFile versionFile sizeDateTimePlatform
Failoverclusters.objectmodel.dll6.0.6002.22134509,44012-May-200916:53x64
For all supported Itanium-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Failoverclusters.objectmodel.dll6.0.6001.22431547,32812-May-200916:52IA-64
For all supported Itanium-based versions of Windows Server 2008 SP2
File nameFile versionFile sizeDateTimePlatform
Failoverclusters.objectmodel.dll6.0.6002.22134547,32812-May-200916:17IA-64

↑ Back to the top


Workaround

To work around this problem, click the "Ignore" button when you receive the error message.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information for Windows Server 2008

Additional files for all supported x86-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Package_for_kb953402_server_0~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,63113-May-200909:15Not Applicable
Package_for_kb953402_server_1~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,52913-May-200909:15Not Applicable
Package_for_kb953402_server~31bf3856ad364e35~x86~~6.0.1.0.mumNot Applicable1,71313-May-200909:15Not Applicable
X86_failoverclusters.objectmodel_31bf3856ad364e35_6.0.6001.22431_none_841055fcec33bc51.manifestNot Applicable7,62112-May-200919:26Not Applicable
X86_failoverclusters.objectmodel_31bf3856ad364e35_6.0.6002.22134_none_85f9c8c2e9575d7a.manifestNot Applicable7,62112-May-200919:23Not Applicable

Additional files for all supported x64-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Amd64_failoverclusters.objectmodel_31bf3856ad364e35_6.0.6001.22431_none_e02ef180a4912d87.manifestNot Applicable7,65112-May-200919:27Not Applicable
Amd64_failoverclusters.objectmodel_31bf3856ad364e35_6.0.6002.22134_none_e2186446a1b4ceb0.manifestNot Applicable7,65112-May-200919:22Not Applicable
Package_for_kb953402_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,64113-May-200909:15Not Applicable
Package_for_kb953402_server_1~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,53913-May-200909:15Not Applicable
Package_for_kb953402_server~31bf3856ad364e35~amd64~~6.0.1.0.mumNot Applicable1,72313-May-200909:15Not Applicable

Additional files for all supported Itanium-based versions of Windows Server 2008

File nameFile versionFile sizeDateTimePlatform
Ia64_failoverclusters.objectmodel_31bf3856ad364e35_6.0.6001.22431_none_8411f9f2ec31c54d.manifestNot Applicable7,63612-May-200919:11Not Applicable
Ia64_failoverclusters.objectmodel_31bf3856ad364e35_6.0.6002.22134_none_85fb6cb8e9556676.manifestNot Applicable7,63612-May-200919:04Not Applicable
Package_for_kb953402_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,63613-May-200909:15Not Applicable
Package_for_kb953402_server_1~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,37013-May-200909:15Not Applicable
Package_for_kb953402_server~31bf3856ad364e35~ia64~~6.0.1.0.mumNot Applicable1,71613-May-200909:15Not Applicable

↑ Back to the top


Keywords: kbqfe, kbclustering, kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, KB953402

↑ Back to the top

Article Info
Article ID : 953402
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 307