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A dump file may not be generated on a computer that is running Windows Server 2008 or Windows Vista if the dump file and the paging file reside on the same volume


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You configure the system to generate a full memory dump file when fatal system errors occur on a computer that is running Windows Server 2008 or Windows Vista.
  • The dump file and the paging file are configured to reside on the same volume.
  • Sufficient free disk space is available on the volume for the dump file. For example, 10 gigabytes (GB) of free disk space is sufficient to save a full memory dump file on a computer that has 8 GB of physical memory.
In this scenario, a memory dump file may not be generated when a fatal system error occurs. However, you find a DumpXXX.tmp file in the location that you specified to save the dump file.

This problem does not occur if the free disk space is larger than two times the size of the physical memory. Additionally, this problem does not occur if the Memory.dmp file already exists.

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Cause

When the dump file and the paging file are configured to reside on the same volume, the Session Manager process (Smss.exe) creates an additional temporary dump file that is unnecessary. Therefore, the free disk space that is required is two times the size of the physical memory instead of only the size of the physical memory.

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Resolution

Hotfix information

Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2008, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Smss.exe6.0.6001.2218964,00029-May-200800:48x86
Windows Server 2008, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Smss.exe6.0.6001.22189159,23229-May-200801:13IA-64
Windows Server 2008, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Smss.exe6.0.6001.2218975,26429-May-200801:22x64

Windows Vista

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Vista, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Smss.exe6.0.6000.2084462,97629-May-200800:46x86
Windows Vista with Service Pack 1, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Smss.exe6.0.6001.2218964,00029-May-200800:48x86
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Smss.exe6.0.6000.2084475,26429-May-200801:07x64
Windows Vista with Service Pack 1, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Smss.exe6.0.6001.2218975,26429-May-200801:22x64

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Workaround

To work around this problem, use one of the following methods:
  • Create an empty Memory.dmp file where the dump file will be saved.
  • Rename the DumpXXX.tmp file as Memory.dmp, and then use the Memory.dmp file as the dump file.
  • Make sure that the free disk space in the memory dump location is larger than two times the size of the physical memory.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseinter, kbautohotfix, kbbug, kbfix, kbqfe, KB953341

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Article Info
Article ID : 953341
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 417