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On a computer that is running Windows Server 2003 or Windows XP, an application experiences an access violation and then crashes if the computer has more than four cores or more than four logical processors


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Windows Server 2003 or Windows XP.
  • The computer has more than four cores or more than four logical processors installed.
  • An application calls functions in the D3d9.dll library for DirectX 3D support.
In this scenario, the application experiences an access violation and then crashes.

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Cause

This issue occurs because DirectX creates worker threads that are based on the number of cores or logical processors. DirectX has a global data array, and each worker thread accesses a dedicated element in that global array. However, there is a hard-coded limitation of four elements in the array. If there are more than four cores or more than four logical processors, some worker threads in DirectX try to access memory that has not been allocated. Therefore, DirectX experiences an access violation issue when it tries to create more than four worker threads.

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Workaround

To work around the issue, do not use more than four processors. You can use the /numproc switch in the Boot.ini file to limit the number of processors. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
833721 Available switch options for the Windows XP and the Windows Server 2003 Boot.ini files

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Resolution

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) must be installed.
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86 version
File nameFile versionFile sizeDateTimePlatform
D3d9.dll5.3.3790.31391,690,62413-May-200814:37x86
Windows Server 2003 with Service Pack 2, x86 version
File nameFile versionFile sizeDateTimePlatform
D3d9.dll5.3.3790.42931,690,62413-May-200815:04x86
Windows Server 2003, x64 version
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
D3d9.dll5.3.3790.31392,098,17613-May-200813:22x64SP1Not Applicable
Wd3d9.dll5.3.3790.31391,690,62413-May-200813:22x86SP1WOW
Windows Server 2003 with Service Pack 2, x64 version
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
D3d9.dll5.3.3790.42932,098,17613-May-200816:07x64SP2Not Applicable
Wd3d9.dll5.3.3790.42931,690,62413-May-200816:07x86SP2WOW

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, Windows XP SP2 or Windows XP SP3 must be installed.
322389 How to obtain the latest Windows XP service pack

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP Professional x64 Edition with SP1, x64 version
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
D3d9.dll5.3.3790.31392,098,17613-May-200813:22x64SP1Not Applicable
Wd3d9.dll5.3.3790.31391,690,62413-May-200813:22x86SP1WOW
Windows XP Professional x64 Edition with SP2, x64 version
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
D3d9.dll5.3.3790.42932,098,17613-May-200816:07x64SP2Not Applicable
Wd3d9.dll5.3.3790.42931,690,62413-May-200816:07x86SP2WOW
Windows XP with Service Pack 2, x86 version
File nameFile versionFile sizeDateTimePlatform
D3d9.dll5.3.2600.33721,689,08813-May-200813:58x86
Windows XP with Service Pack 3, x86 version
File nameFile versionFile sizeDateTimePlatform
D3d9.dll5.3.2600.56011,689,08813-May-200813:53x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: kbautohotfix, kbexpertiseadvanced, kbhotfixserver, kbqfe, KB953028

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Article Info
Article ID : 953028
Revision : 2
Created on : 5/21/2008
Published on : 5/21/2008
Exists online : False
Views : 291