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Some e-mail messages may be stuck in the Categorizer component in an Exchange Server 2003 environment


View products that this article applies to.

Symptoms

In a Microsoft Exchange Server 2003 environment, some e-mail messages may be stuck in the Categorizer component. To determine whether this issue has occurred, you can use the Message Tracking Center.

When this problem occurs, the following errors are logged in the Application log:

Event ID : 9005
Category : Categorizer
Source : MSExchangeTransport
Type : Warning
Message : Categorizer is unable to initialize. The function 'm_DSInfo.HrInit' returned error code '0x80040920' ().

Event ID : 9002
Category : Categorizer
Source : MSExchangeTransport
Type : Error
Message : Categorizer encountered a hard error while processing a message. The function 'CPhatCat::Register' called 'Initialize' which returned error code '0x80040920' (). ( f:\tisp2\transmt\src\cat\sinks\phatcat\phatcat.cpp@454 )

Event ID : 6006
Category : Categorizer
Source : MSExchangeTransport
Type : Warning
Message : Categorizer is temporarily unable to process a message. The function 'CCategorizer: elayedInitializeIfNecessary' called 'DelayedInitialize' which returned error code '0xc0040555' (). ( f:\tisp2\transmt\src\phatq\cat\inc\ccatfn.h@123 )

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Cause

This problem occurs because some Simple Mail Transfer Protocol (SMTP) virtual servers are deleted from Exchange System Manager. However, entries for these SMTP virtual servers still exist in the Internet Information Services (IIS) metabase.

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Resolution

To resolve this problem, follow these steps:
  1. Install IIS 6.0 Resource Kit Tools. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
    840671 The IIS 6.0 Resource Kit Tools
  2. Open IIS Metabase Explorer.
  3. Expand LM, and then expand SmtpSvc.
  4. Expand 1.

    Note There are two items that are listed under SmtpSvc. If you expand the other item, you can see valid domain names. This result indicates that 1 is a stale entry and that it can be deleted.
  5. Right-click 1, and then click Delete.
  6. Restart the Simple Mail Transfer Protocol service and the Microsoft Routing Engine service.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB952841, kbprb, kbexpertiseinter, kbtshoot

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Article Info
Article ID : 952841
Revision : 1
Created on : 6/2/2008
Published on : 6/2/2008
Exists online : False
Views : 220