Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Error message when you try to open a 2007 Office system file attachment in Outlook Web Access: "To open this attachment, you must save it to your disk"


View products that this article applies to.

Symptoms

When you try to open a 2007 Microsoft Office system file attachment by using Microsoft Office Outlook Web Access, you may receive the following error message:
To open this attachment, you must save it to your disk, right-click the link, and then click Save.
This problem occurs if the following conditions are true:
  • The e-mail message is sent by using Outlook 2003 or by using Outlook 2007.
  • You read the e-mail message in Outlook Web Access.
Note This problem does not occur if the e-mail is sent by using Outlook Express or by using Outlook Web Access.

↑ Back to the top


Cause

This problem occurs because of the Exchange Server 2003 component that is used to convert the Outlook MAPI e-mail message to a MIME e-mail message type that Outlook Web Access can read. Because this component cannot recognize the new 2007 Office system file formats, you experience the problem that is described in the "Symptoms" section.

↑ Back to the top


Resolution

To resolve this problem, add the 2007 Office system content types to Exchange so that the conversion process can recognize these content types. A content type is a string that has a file name extension associated with it. To add the string and the associated file name extension, use Exchange System Manager. To do this, follow these steps:
  1. Open Exchange System Manager.
  2. Expand Global Setting Branch.
  3. Right-click Internet Message Formats, and then click Properties. This operation displays the current list of known MIME content types.
  4. Examine the list, and confirm that the 2007 Office system file name extensions are not in the list.
  5. Click Add, and then copy and paste the appropriate MIME type from the following table in the text box that is provided. Additionally, type the appropriate file name extension that corresponds to the MIME type in the Extension check box.
    MIME typeFile name extension
    application/vnd.openxmlformats-officedocument.presentationml.presentationpptx
    application/vnd.openxmlformats-officedocument.presentationml.slidesldx
    application/vnd.openxmlformats-officedocument.presentationml.slideshowppsx
    application/vnd.openxmlformats-officedocument.presentationml.templatepotx
    application/vnd.openxmlformats-officedocument.spreadsheetml.sheetxlsx
    application/vnd.openxmlformats-officedocument.spreadsheetml.templatexltx
    application/vnd.openxmlformats-officedocument.wordprocessingml.documentdocx
    application/vnd.openxmlformats-officedocument.wordprocessingml.templatedotx
  6. Click OK.
  7. Restart the Microsoft Exchange Information Store Service to make sure that the store obtains the new list.
  8. Restart Outlook, and send a new test e-mail message that includes a 2007 Office system file attachment. For comparison, send an e-mail message that contains the same attachment by using Outlook Web Access.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB952770, kbprb, kbexpertiseinter, kbtshoot

↑ Back to the top

Article Info
Article ID : 952770
Revision : 1
Created on : 5/29/2008
Published on : 5/29/2008
Exists online : False
Views : 203