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A printer-driver upgrade operation fails on printer clients that are running Windows Server 2003 or Windows XP when multiple printer queues are upgraded at the same time


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You install multiple printers on a printer server. Printer clients that are running Windows Server 2003 or Windows XP create network printers by using this printer server.
  • On the printer server, you upgrade all the printer drivers at the same time. Additionally, these printer drivers share one or more of the same binary files.
  • After the drivers are updated on the server, the printer clients upgrade their printer queues at the same time.
In this scenario, some printer driver files are not upgraded on the printer clients. Therefore, some printer clients cannot use these network printers.

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Cause

This problem occurs because of an error in the spooler process.

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Resolution

A hotfix is available to resolve this problem. Apply this hotfix to the printer clients that are running Windows Server 2003 or Windows XP.

Hotfix information for Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To enable this hotfix, follow these steps.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type SerializeDriverInstallsAndUpgrades, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 0, 1, or 2, and then click OK.
  7. Exit Registry Editor.
If the value of the SerializeDriverInstallsAndUpgrades registry entry is set to 0, all upgrades of printer drivers from all printer manufacturers can be performed at the same time. This is the same as if the hotfix had not been applied.

If the value of the SerializeDriverInstallsAndUpgrades registry entry is set to 1, all upgrades of printer drivers from the same printer manufacturer are serialized. In this situation, there can be multiple upgrades of printer drivers from different printer manufacturers in progress at the same time. However, if two printer drivers are from the same printer manufacturer, the upgrades of these drivers cannot be performed at the same time.

If the value of the SerializeDriverInstallsAndUpgrades registry entry is set to 2, all upgrades of printer drivers from all printer manufacturers are serialized. In this situation, there can be only one upgrade of a printer driver from any printer manufacturer at any particular time.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.3141349,18415-May-200817:48x86
Windows Server 2003 with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4295343,04015-May-200818:02x86
Windows Server 2003, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.3141751,61615-May-200816:38x64
Windows Server 2003 with SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4295751,10415-May-200816:39x64
Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.3141970,75215-May-200816:37IA-64
Windows Server 2003 with SP2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.2.3790.4295971,77615-May-200816:38IA-64

Hotfix information for Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP SP2 or Windows XP SP3 installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To enable this hotfix, follow these steps.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type SerializeDriverInstallsAndUpgrades, and then press ENTER.
  5. On the Edit menu, click Modify.
  6. Type 0, 1, or 2, and then click OK.
  7. Exit Registry Editor.
If the value of the SerializeDriverInstallsAndUpgrades registry entry is set to 0, all upgrades of printer drivers from all printer manufacturers can be performed at the same time. This is the same as if the hotfix had not been applied.

If the value of the SerializeDriverInstallsAndUpgrades registry entry is set to 1, all upgrades of printer drivers from the same printer manufacturer are serialized. In this situation, there can be multiple upgrades of printer drivers from different printer manufacturers in progress at the same time. However, if two printer drivers are from the same printer manufacturer, the upgrades of these drivers cannot be performed at the same time.

If the value of the SerializeDriverInstallsAndUpgrades registry entry is set to 2, all upgrades of printer drivers from all printer manufacturers are serialized. In this situation, there can be only one upgrade of a printer driver from any printer manufacturer at any particular time.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.1.2600.3374343,55215-May-200816:18x86
Windows XP with SP3, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Localspl.dll5.1.2600.5603343,55215-May-200815:39x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbqfe, kbhotfixserver, KB952206

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Article Info
Article ID : 952206
Revision : 2
Created on : 7/1/2008
Published on : 7/1/2008
Exists online : False
Views : 295