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A program that runs under the NT Authority\System account does not recognize environment variable changes on a Windows Server 2003-based computer until you restart the computer


View products that this article applies to.

Symptoms

On a Windows Server 2003-based computer, a program that is running under the NT Authority\System account does not recognize environment variable changes until you restart the computer.

For example, if you change the Path environment variable by using the System Properties item in Control Panel, a program that is running under the NT Authority\System account that uses the Path environment variable does not recognize the change until you restart your computer.

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Cause

When a program runs under the NT Authority\System Account, the system does not call the CreateEnvironmentBlock function to retrieve the latest environment variables. Therefore, the program inherits the environment block from the program's parent process. This environment block was set up before the environment variables were changed.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Schedsvc.dll5.2.3790.3136202,24008-May-200817:41x86
Windows Server 2003 with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Schedsvc.dll5.2.3790.4290202,24008-May-200818:06x86
Windows Server 2003 with SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Schedsvc.dll5.2.3790.3136579,58408-May-200817:22IA-64SP1Not applicable
Wschedsvc.dll5.2.3790.3136202,24008-May-200817:22x86SP1WOW
Windows Server 2003 with SP2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Schedsvc.dll5.2.3790.4290578,56008-May-200817:24IA-64SP2Not applicable
Wschedsvc.dll5.2.3790.4290202,24008-May-200817:24x86SP2WOW
Windows Server 2003 and Windows XP, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Schedsvc.dll5.2.3790.3136315,39208-May-200817:22x64SP1Not applicable
Wschedsvc.dll5.2.3790.3136202,24008-May-200817:22x86SP1WOW
Windows Server 2003 with SP2 and Windows XP with SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Schedsvc.dll5.2.3790.4290314,88008-May-200817:24x64SP2Not applicable
Wschedsvc.dll5.2.3790.4290202,24008-May-200817:24x86SP2WOW

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Workaround

To work around the issue, run the program under an account other than the NT Authority\System account.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

System variables are saved in the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
For more information about the CreateEnvironmentBlock function, visit the following Microsoft Web site: For more information about a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:
887693 Service does not recognize a Windows environment variable change on a Windows Server 2003-based computer
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbqfe, KB951859

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Article Info
Article ID : 951859
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 351