Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Non-administrators cannot log on to the console of the computers that are running Windows Server 2008 if locale information is set in Group Policy Preferences


View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows

↑ Back to the top


Symptoms

Consider the following scenario. You enable the locale Group Policy Preferences setting in a domain policy and configure it to apply to the computers that are running Windows Server 2008. The URL path for the locale Group Policy Preferences setting is as follows:
User -> Preference -> Control Panel Settings -> Regional Option – User Locale – enabled (F5)
Note In some environments, just enabling the policy creates a reproduction of the problem. Other users reported that changing the locale to a value other than "English (United States)" such as "English (United Kingdom)" was required.


In this scenario, you encounter one or more of the following issues:
  • The Windows Event Log service does not fully start.



    The Services snap-in, services.msc, displays the service status for the Windows Event Log service as the "Starting…"status.
  • The DNS Server service does not start on the computers that are running Windows Server 2008 and that apply the locale policy.



    The Services snap-in (services.msc) displays the service status for the DNS Server service by using a null status that means "not started," "stopped," or "paused."

    When you try to start the DNS Server service, it fails, and you receive the following error message:
    Error 1722: The RPC server is unavailable.


    Computers that point to these DNS servers that are in this state cannot resolve DNS names on the corporate network or on the Internet unless an alternative DNS server is configured and is responding to DNS queries. Windows Server 2008 DNS Servers that are subjected to this policy may be affected.

    Note The DNS Client service is not affected by this policy.
  • The Task Scheduler service does not start on the computers that are running Windows Server 2008 and that apply the locale policy.



    The Services snap-in (services.msc) displays the service status for the Task Scheduler service by using a null status that means "not started," "stopped," or "paused."



    When you try to start the DNS Server service, it fails, and you receive the following error message:
    Error 1053: The service did not to the start or control request in a timely fashion.
  • When you try to open Event Viewer, it fails, and you receive the following error message:
    Event Log service is unavailable. Verify that the service is running.
  • Logon experience is only affected if users log on to a computer that is running Windows Server 2008 and that is pointed to an affected DNS server.

↑ Back to the top


Cause

This problem occurs because the Group Policy preference setting sets incorrect locale data into a registry key.

This behavior causes an exception in the Windows Event Log service. Therefore, the logon attempt by the user fails.

The Task Scheduler service has a “depends on” relationship with the Windows Event Log service.



The DNS Server service does not have a "depends on" relationship with Windows Event Log service. However, the auditing requirements prevent in DNS Server service that is in Windows Server 2008 from starting if security events cannot be logged.

↑ Back to the top


Resolution

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve these problems, follow these steps and then apply this hotfix:
  1. Click StartStart button , type
    regedit
    in the Start Search box, and then press ENTER.
  2. Locate the following registry subkey:
    HKEY_USERS\.DEFAULT\Control Panel\International
  3. Double-click the Locale registry entry.
  4. In the Value data box, change the data to
    0000809, and then click OK.
  5. On the File menu, click Exit.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.



Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the “Hotfix Request” page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.

Prerequisites

To apply this hotfix, your computer must be running one of the following operating systems:
  • Windows Server 2008
  • Windows Server 2008 Service Pack 2 (SP2)

Restart requirement

You must restart the computer after you apply this hotfix.

Registry information

The hotfix does not resolve the issue but will prevent the issue.


To prevent the problem, set the following registry value to 0000809:
HKEY_USERS\.Default\Control Panel\International\Locale

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
For all supported x86-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatform
Gpprefcl.dll6.0.6001.22474638,97617-Jul-200914:26x86
Gpprefcl.dll6.0.6002.22179638,97617-Jul-200914:16x86
For all supported x64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gpprefcl.dll6.0.6001.22474833,02417-Jul-200914:37x64SP1Not Applicable
Gpprefcl.dll6.0.6001.22474638,97617-Jul-200914:26x86SP1WOW
Gpprefcl.dll6.0.6002.22179833,02417-Jul-200914:07x64SP2Not Applicable
Gpprefcl.dll6.0.6002.22179638,97617-Jul-200914:16x86SP2WOW
For all supported IA-64-based versions of Windows Server 2008
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Gpprefcl.dll6.0.6001.224741,646,59217-Jul-200914:34IA-64SP1Not Applicable
Gpprefcl.dll6.0.6001.22474638,97617-Jul-200914:26x86SP1WOW
Gpprefcl.dll6.0.6002.221791,646,59217-Jul-200914:00IA-64SP2Not Applicable
Gpprefcl.dll6.0.6002.22179638,97617-Jul-200914:16x86SP2WOW

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates


↑ Back to the top


Keywords: kb, kbautohotfix, kbexpertiseadvanced, kbfix, kbsurveynew, kbqfe, kbhotfixserver

↑ Back to the top

Article Info
Article ID : 951430
Revision : 4
Created on : 3/30/2017
Published on : 3/30/2017
Exists online : False
Views : 233