Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Devices that stream data over more than two isochronous channels by using IEEE 1394 connections may have choppy or distorted output on a Windows-based computer


View products that this article applies to.

Symptoms

On a Windows-based computer, devices that stream data over more than two isochronous channels by using IEEE 1394 connections may have choppy or distorted output. Typically, the issue occurs when multiple instances of isochronous data, such as audio data and video data, are streamed over the IEEE 1394 connections.

Note This problem may also occur on a single physical device that has multiple channels of isochronous data. For example, this problem may also occur on an audio mixing board that outputs multiple audio channels over separate isochronous channels.

For example, you may have multiple digital video cameras, audio input devices, or both, that are connected to the computer by using the IEEE 1394 connections. In this case, streaming video that is output from the digital video cameras may appear choppy and may not have a smooth and steady frame rate. Steaming audio from the audio devices may have distorted sound.

This issue may occur on the following Microsoft Windows operating systems:
  • Windows XP
  • 64-bit versions of Windows Server 2003
  • Windows Vista
  • Windows Server 2008

↑ Back to the top


Cause

This problem occurs because of a problem in the Microsoft-provided IEEE 1394 host controller driver (Ohci1394.sys).

↑ Back to the top


Resolution

Hotfix information

Windows XP

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have Windows XP Service Pack 2 or a later service pack installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389� How to obtain the latest Windows XP service pack
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix replaces the hotfixes that are described in the following Microsoft Knowledge Base articles:
885464� SBP-2 drive stops responding when you try to write data in Windows XP
895312� You may not be able to open files that you copied to an external IEEE 1394 SBP2 hard disk in Windows XP or Windows Server 2003
904412� An SBP-2 device does not work when it is connected to a Windows XP SP2-based computer
952825� IEEE 1394-compliant storage devices that are connected to an OHCI host controller are not displayed on a Windows XP-based computer
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ohci1394.sys5.1.2600.341561,44023-Jul-200810:23x86

Windows XP with Service Pack 3, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ohci1394.sys5.1.2600.564661,82423-Jul-200810:34x86

64-bit versions of Windows Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
To apply this hotfix, you must have 64-bit versions of Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix replaces the hotfixes that are described in the following Microsoft Knowledge Base articles:
895312� You may not be able to open files that you copied to an external IEEE 1394 SBP2 hard disk in Windows XP or Windows Server 2003
931911� TCP/IP activities that depend on an IEEE 1394 connection are unavailable on a Windows Server 2003 x64 Edition-based computer
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ohci1394.sys5.2.3790.319393,69618-Aug-200813:19x64

Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ohci1394.sys5.2.3790.435693,69618-Aug-200813:42x64

Windows XP x64-based versions with Service Pack 1
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ohci1394.sys5.2.3790.319393,69618-Aug-200813:19x64

Windows XP x64-based versions with Service Pack 2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ohci1394.sys5.2.3790.435693,69618-Aug-200813:42x64

Windows Vista and Windows Server 2008

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Important Windows Vista and Windows Server 2008 hotfixes are included in the same packages. However, only one of these products may be listed on the �Hotfix Request� page. To request the hotfix package that applies to both Windows Vista and Windows Server 2008, just select the product that is listed on the page.
Prerequisites
No prerequisites are required.
Restart requirement
You must restart the computer after you apply this hotfix.
Hotfix replacement information
This hotfix replaces the hotfixes that are described in the following Microsoft Knowledge Base articles:
930495� An IEEE 1394 device is no longer available when you wake a Windows Vista-based computer from sleep or after you reconnect the device
934314� Performance is slower than you expect when you read from or write to an IEEE 1394 hard disk that uses a VIA Technologies 1394 host controller in Windows Vista
952824� IEEE 1394-compliant storage devices that are connected to an OHCI host controller are not displayed in Device Manager on a Windows Vista-based computer
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista and Windows Server 2008 file information notes
  • The files that apply to a specific product, milestone (RTM, SPn) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.0.6000.20xxx Windows RTM LDR
    6.0.6001.22xxxWindows Vista SP1 and Windows Server 2008 SP1 SP1 LDR
  • Service Pack 1 is integrated into Windows Server 2008. Therefore, RTM milestone files apply only to Windows Vista. RTM milestone files have a 6.0.0000.xxxxxx version number.
  • The .manifest files and the .mum files that are installed in each environment are listed separately in the "Additional file information for Windows Server 2008 and for Windows Vista" section. These files and their associated .cat (security catalog) files are critical to maintaining the state of the updated component. The .cat files are signed with a Microsoft digital signature. The attributes of these security files are not listed.
For all supported x86-based versions of Windows Server 2008 and Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
1394bus.sys6.0.6000.2088153,37624-Jul-200801:13x86
Ohci1394.sys6.0.6000.2088162,20824-Jul-200801:13x86
1394bus.sys6.0.6001.2222853,37624-Jul-200801:19x86
Ohci1394.sys6.0.6001.2222862,08024-Jul-200801:19x86

For all supported x64-based versions of Windows Server 2008 and Windows Vista
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
1394bus.sys6.0.6000.2088165,02424-Jul-200801:29x64
Ohci1394.sys6.0.6000.2088172,32024-Jul-200801:29x64
1394bus.sys6.0.6001.2222865,28024-Jul-200801:46x64
Ohci1394.sys6.0.6001.2222872,44824-Jul-200801:46x64

For all supported Itanium-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
1394bus.sys6.0.6001.22228175,61624-Jul-200801:43IA-64
Ohci1394.sys6.0.6001.22228171,90424-Jul-200801:43IA-64
Additional file information for Windows Server 2008 and Windows Vista

Additional files for all supported x86-based versions of Windows Server 2008 and Windows Vista
Collapse this tableExpand this table
File namePackage_1_for_kb951410~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,802
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_2_for_kb951410~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,969
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_3_for_kb951410~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,807
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_4_for_kb951410~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,807
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_5_for_kb951410~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,807
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_6_for_kb951410~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,803
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_client_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,426
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_client_1~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,367
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_client~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,713
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_sc_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,421
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_sc~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,423
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_server_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,425
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_server~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,431
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_winpesrv_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,422
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_winpesrv~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_winpe_0~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,420
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_winpe~31bf3856ad364e35~x86~~6.0.1.0.mum
File versionNot Applicable
File size1,424
Date (UTC)24-Jul-2008
Time (UTC)17:21
File nameX86_1394.inf_31bf3856ad364e35_6.0.6000.20881_none_f97d3794221ef6f1.manifest
File versionNot Applicable
File size2,651
Date (UTC)24-Jul-2008
Time (UTC)17:24
File nameX86_1394.inf_31bf3856ad364e35_6.0.6001.22228_none_fbab57c81f0e919d.manifest
File versionNot Applicable
File size2,651
Date (UTC)24-Jul-2008
Time (UTC)17:24

Additional files for all supported x64-based versions of Windows Server 2008 and Windows Vista
Collapse this tableExpand this table
File nameAmd64_1394.inf_31bf3856ad364e35_6.0.6000.20881_none_559bd317da7c6827.manifest
File versionNot Applicable
File size2,653
Date (UTC)24-Jul-2008
Time (UTC)17:26
File nameAmd64_1394.inf_31bf3856ad364e35_6.0.6001.22228_none_57c9f34bd76c02d3.manifest
File versionNot Applicable
File size2,653
Date (UTC)24-Jul-2008
Time (UTC)17:26
File namePackage_1_for_kb951410~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,812
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_2_for_kb951410~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,981
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_3_for_kb951410~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,817
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_4_for_kb951410~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,817
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_5_for_kb951410~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,817
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_6_for_kb951410~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,813
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_client_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,434
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_client_1~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,375
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_client~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,723
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_sc_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,429
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_sc~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,431
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_server_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,433
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_server~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,439
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_winpesrv_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,430
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_winpesrv~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,438
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_winpe_0~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,428
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_winpe~31bf3856ad364e35~amd64~~6.0.1.0.mum
File versionNot Applicable
File size1,432
Date (UTC)24-Jul-2008
Time (UTC)17:21

Additional files for all supported Itanium-based versions of Windows Server 2008
Collapse this tableExpand this table
File nameIa64_1394.inf_31bf3856ad364e35_6.0.6001.22228_none_fbacfbbe1f0c9a99.manifest
File versionNot Applicable
File size2,652
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_1_for_kb951410~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,807
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_2_for_kb951410~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,812
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_3_for_kb951410~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,812
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_sc_0~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,425
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_sc~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,426
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_server_0~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,429
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_server~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,434
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_winpesrv_0~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,426
Date (UTC)24-Jul-2008
Time (UTC)17:21
File namePackage_for_kb951410_winpesrv~31bf3856ad364e35~ia64~~6.0.1.0.mum
File versionNot Applicable
File size1,433
Date (UTC)24-Jul-2008
Time (UTC)17:21

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More information

When multiple isochronous streams are transferred on an IEEE 1394 bus, callbacks are registered by the IEEE 1394 client device driver for each isochronous descriptor. However, these callbacks may not be called back when the isochronous transfer is completed. In this case, the missed callbacks are called back after an interrupt is issued by the host controller.

This problem typically occurs when there are three or more concurrently-active isochronous channels. This usually does not occur with two or fewer active isochronous channels.

Note Theoretically, this problem may occur with any number of active isochronous channels.

For more information about isochronous I/O for IEEE 1394 devices, visit the following Web site:

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:
Related Information:

Troubleshooter: No audio in Windows

Music and sound help with Windows 7

↑ Back to the top


Keywords: kbautohotfix, kbexpertiseinter, kbfix, kbbug, kbqfe, KB951410

↑ Back to the top

Article Info
Article ID : 951410
Revision : 2
Created on : 6/25/2010
Published on : 6/25/2010
Exists online : False
Views : 426