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After you enable the dynamic backlog settings on a Windows Server 2003-based computer, the System Handle count and the nonpaged pool usage may increase significantly


View products that this article applies to.

Symptoms

On a Windows Server 2003-based computer, you may decide to use the Afd.sys driver to enable the dynamic backlog settings. You do this to harden the TCP/IP stack against SYN attacks.

Note You configure the dynamic backlog settings according to the instructions in the following Microsoft Knowledge Base article:
142641 Internet server unavailable because of malicious SYN attacks
In this scenario, the System Handle count and the nonpaged pool memory usage may increase significantly. Eventually, the nonpaged pool memory may be exhausted, and then the system stops responding (hangs).

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Cause

When the dynamic backlog is triggered to create new connections, the Afd.sys driver creates connections according to the value of the DynamicBacklogGrowthDelta registry entry. However, under certain circumstances, the driver may incorrectly create connections according to the value of the MaximumDynamicBacklog registry entry.

Because of this incorrect behavior, the Afd.sys driver creates many unnecessary connections. Therefore, the System Handle count and the nonpaged pool memory usage increase significantly.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 SP1, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.3175153,08816-Jul-200810:47x86
Windows Server 2003 SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.4335150,52816-Jul-200811:16x86
Windows Server 2003 SP1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.3175584,19216-Jul-200812:29IA-64
Windows Server 2003 SP2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.4335584,19216-Jul-200812:32IA-64
Windows Server 2003 and Windows XP, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.3175299,52016-Jul-200812:29x64
Windows Server 2003 SP2 and Windows XP SP2, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Afd.sys5.2.3790.4335292,35216-Jul-200812:34x64

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Workaround

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
To work around this issue, disable the backlog settings. To do this, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK .
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\AFD\Parameters
  3. Right-click the EnableDynamicBacklog registry entry, and then click Modify.
  4. In the Value data box, type 0, and the click OK.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The Afd.sys driver is expected to create free connections according to the value of the DynamicBacklogGrowthDelta registry entry when the following conditions are true.
  • The current number of free connections is less than the value of the MinimumDynamicBacklog registry entry.
  • The sum of the current number of free connections and the current number of half-connected (SYN_RECEIVED) connections is less than the value of the MaximumDynamicBacklog registry entry.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbqfe, KB951162

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Article Info
Article ID : 951162
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 313