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You may receive an error message on a Windows Server 2003-based computer that has Citrix Presentation Server 4.0 installed


View products that this article applies to.

Symptoms

On a Windows Server 2003-based computer that has Citrix Presentation Server 4.0 installed, you may experience the following symptoms:
  • When you try to install an .msi package, you may receive the following error message:
    Windows Installer
    ==============
    The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not correctly installed. Contact your support personnel for assistance.
  • When you try to install an .msi package, the system may respond slowly. When you start Task Manager, you may notice that Task Manager indicates high CPU usage for the MSIExec process.
  • Windows Internet Explorer or other applications may take 30 seconds to 3 minutes to start. Additionally, the Windows Installer service is in a "Started" state after the application starts.

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Cause

This problem may occur because of an issue in the CtxSbxHook.dll file from Citrix. TheCtxSbxHook.dll file is related to the Application Isolation Environment feature in Citrix Presentation Server.

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Resolution

To resolve this problem, contact Citrix for more help. You can also download a Citrix hotfix to upgrade the Citrix components. To do this, visit the following Citrix Web site: For information about how to contact Citrix, click the appropriate article number in the following list to view the article in the Microsoft Knowledge Base:
65416� Hardware and software vendor contact information, A-K

60781� Hardware and software vendor contact information, L-P

60782� Hardware and software vendor contact information, Q-Z


Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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Workaround

To work around this problem, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\Software\citrix\ctxhook\appinit_dlls\ctxsbxhook
  3. In the details pane, double-click the hookmsi registry entry.
  4. In the Value data box, type 0, and then click OK.
  5. Exit Registry Editor.

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More information

For more information about the Application Isolation Environment feature, visit the following Citrix Web site:The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: kbexpertiseinter, kbtshoot, kbprb, KB951032

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Article Info
Article ID : 951032
Revision : 1
Created on : 4/21/2008
Published on : 4/21/2008
Exists online : False
Views : 225