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An application may be unresponsive, documents may not print, and event IDs 6162 or 61 may be logged on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

One or more of the following symptoms may occur in a computer that is running Windows Server 2003:
  • A program may be unresponsive and may appear to stop responding.
  • A document does not print.
  • The following event message may be logged in the System log for Window Server 2003 Service Pack 1 (SP1) or for Windows Server 2003 Service Pack 2 (SP2):

    Event Type: Error
    Event Source: Print
    Event ID: 6162
    Date: Date
    Time: Time
    User: UserName
    Computer: ComputerName
    Description: The spooler has detected that a component has an unusually large number of open GDI objects. As a result some EMF print jobs might not print until the spooler is restarted.

  • The following event message may be logged in the System log for the release version of Window Server 2003:

    Event Type: Error
    Event Source: Print
    Event Category: None
    Event ID: 61
    Description: The document <document name> owned by <username> failed to print on printer <printer name>. Win32 error code returned by the print processor: 3003. A StartDocPrinter call was not issued.

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Cause

This problem occurs because of one or more of the following reasons.

Cause 1

There is a bad client application. For example, when you print an image document, such as an .mdi file, a .tif file, or a .tiff file from Microsoft Office 2003 Document Imaging to a printer, you may experience resource limitations in the Graphics Device Interface (GDI).

Cause 2

There is a very large print job that contains Enhanced Meta File (EMF) format files, and these EMF files contain lots of raster data.

Cause 3

You did not install the following security update:
925902 MS07-017: Vulnerability in GDI could allow remote code execution
Cause 4

You installed third-party print processors and print monitors.

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Resolution

To resolve this problem, use one of the following methods, as appropriate for your situation.

Method 1

If Office 2003 is installed on the computer and on the Terminal Servers, install the hotfix package that is described in the following Microsoft Knowledge Base article:
896604 Description of the Microsoft Office 2003 post-Service Pack 1 hotfix package: April 6, 2005
Note Office 2003 has been updated with several service packs since Service Pack 1.

Method 2

To resolve this problem, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\ CurrentVersion\Windows
  3. In the details pane, double-click the GDIProcessHandleQuota registry entry.
  4. In the Value data box, type a number from 15000 through 20000, and then click OK.
  5. Exit Registry Editor.
By default, applications that are running in Windows Server 2003 cannot create more than 10,000 user objects or more than 10,000 GDI objects.

Method 3

To resolve this problem, follow these steps:
  1. Install the latest hotfix for the Gdi32.dll file (version 5.2.3790.2960) from the following Microsoft Knowledge Base article:
    938829 MS07-046: Vulnerability in GDI could allow remote code execution
  2. Install the latest hotfix for the Win32k.sys file (version 5.2.3790.2892) from the following Microsoft Knowledge Base article:
    925902 MS07-017: Vulnerability in GDI could allow remote code execution
Method 4

To resolve this problem, update the print driver for the third-party printer.

Method 5

If the hotfixes that are mentioned in the "Method 1" and "Method 3" sections do not resolve the problem, try to determine which application causes the problem. To do this, follow these steps:
  1. Interactively log on to the file server.

    Note Do not use Remote Desktop Connection (Mstsc.exe) to log on to the file server.
  2. Right-click the taskbar, and then click Task Manager.
  3. On the View menu, click Select Columns.
  4. Click to select the GDI Objects check box, and then click OK.
  5. In Task Manager, click the Processes tab, and watch the value of the GDI Objects column to make sure that the objects do not exceed 5,000. If the objects start to exceed 5,000, examine the GDI object count increments. Notice that they do not go down when the printer is printing the .tif or .tiff files.
  6. Open the System log to find the origin and the type (.tif or .tiff) of the print jobs that are entering the print queue.
  7. Export the System log as a text file.
  8. Press CTRL+F to find the .tif files or the .tiff files.
  9. Note the end-users' names, and contact them to determine the application that they used to send those specific print jobs. After you have the application list, contact the application vendor to determine whether there is a fix.

    If this application is a Microsoft application, the fix may already be part of a hotfix or a service pack, or there may be a workaround for this problem.

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Keywords: kbexpertiseinter, kbtshoot, kbprb, KB951009

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Article Info
Article ID : 951009
Revision : 1
Created on : 5/15/2008
Published on : 5/15/2008
Exists online : False
Views : 267