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The system may not detect that a logical unit was replaced on a Windows Server 2003-based computer


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a Windows Server 2003-based computer that is connected to a disk array by using the Storport miniport driver.
  • You expose a logical unit to the computer.
  • You replace the logical unit with a second logical unit.
  • You scan for hardware changes in Device Manager.
In this scenario, the system may not detect that the original logical unit was replaced. Therefore, applications may write incorrectly to the original logical unit, and data corruption may occur.

This problem typically occurs when the original logical unit and the second logical unit have identical vendor-specific identifiers in the SCSI Inquiry page 0x83.

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Cause

This problem occurs because the Storport driver uses an incorrect comparison algorithm for the SCSI Inquiry page 0x83.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.320518,94404-Sep-200812:24x86SP1
Storport.sys5.2.3790.3205108,03204-Sep-200812:24x86SP1
Windows Server 2003 with Service Pack 2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.436818,94404-Sep-200812:39x86SP2
Storport.sys5.2.3790.4368108,03204-Sep-200812:39x86SP2
Windows Server 2003 with Service Pack 1, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.320549,66404-Sep-200815:54IA-64SP1
Storport.sys5.2.3790.3205347,13604-Sep-200815:54IA-64SP1
Windows Server 2003 with Service Pack 2, Itanium-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.436849,66404-Sep-200815:59IA-64SP2
Storport.sys5.2.3790.4368347,13604-Sep-200815:59IA-64SP2
Windows Server 2003 with Service Pack 1, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.320524,06404-Sep-200815:54x64SP1
Storport.sys5.2.3790.3205187,90404-Sep-200815:54x64SP1
Windows Server 2003 with Service Pack 2, x64-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Diskdump.sys5.2.3790.436824,06404-Sep-200816:02x64SP2
Storport.sys5.2.3790.4368188,92804-Sep-200816:02x64SP2

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbexpertiseadvanced, kbexpertiseinter, kbautohotfix, kbwinserv2003postsp2fix, kbbug, kbfix, kbqfe, KB950903

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Article Info
Article ID : 950903
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 368