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FIX: BizTalk does not consume messages when the Ordered Delivery feature is enabled


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You use a custom, consuming pipeline component that can return a NULL value in Microsoft BizTalk Server 2006 R2.
  • You enable the Ordered Delivery feature at the Send Port level.
In this scenario, if the pipeline component returns a NULL value, the messages stay in an Active status. BizTalk never consumes the messages. Because of the Ordered Delivery feature, BizTalk cannot process any later messages.

Note When a general pipeline component receives a message from the BizTalk Messaging Engine, the general pipeline component processes the message. Then, the general pipeline component returns the message to the BizTalk Server engine. However, you can implement general components so that the components do not return messages to the server.These components are called consuming components because the component receives the messages but does not produce any messages.

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Cause

This problem occurs because of an issue in the BizTalk Messaging engine.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Microsoft BizTalk Server 2006 R2 installed to apply this hotfix.

Restart requirement

You must restart the BizTalk host instance or instances after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
BizTalk Server 2006 R2, x86
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Btsmessageagent.dll3.6.1478.2697,36019-Jul-2008 4:53x86
Btsmsgcore.dll3.6.1478.21,226,24819-Jul-2008 4:53x86
Microsoft.biztalk.globalpropertyschemas.dll3.6.1478.21,094,72019-Jul-2008 4:51x86
BizTalk Server 2006 R2, x64
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Btsmessageagent.dll3.6.1478.21,347,08819-Jul-20084:55x64
Btsmsgcore.dll3.6.1478.21,961,99219-Jul-20084:55x64
Note This hotfix includes the x86 platform files and the x64 platform files in a single hotfix package. When you install this hotfix, this hotfix updates the files based on your computer platform.

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about developing custom pipeline components, visit the following Microsoft Web site: For more information about ordered delivery, visit the following Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: KB950878, kbqfe, kbhotfixserver, kbexpertiseinter, kbautohotfix, kbsurveynew

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Article Info
Article ID : 950878
Revision : 1
Created on : 2/19/2009
Published on : 2/19/2009
Exists online : False
Views : 434