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FIX: You receive an error message when you configure the "BizTalk EDI/AS2 Runtime" option in BizTalk Server 2006 R2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a computer that is running Microsoft BizTalk Server 2006 R2.
  • You configure the "BizTalk EDI/AS2 Runtime" optionby using Microsoft BizTalk Server 2006 Configuration.
  • You select the "Enable BizTalk EDI/AS2 Runtime Status Reporting for this BizTalk Group" option and then click "Apply Configuration" to continue.
In this scenario, the configuration fails. Additionally, an error message is logged in the configuration log file that resembles the following:
[<Time> Error EDIAS2Config] Failed to configure EDI/AS2 Status Reporting functionalities. (Microsoft.BizTalk.Configuration.EDIAS2.StatusReportingHelper)
Failed to add BizTalk Group (<group name>) to SQL roles. (Microsoft.BizTalk.Configuration.EDIAS2.EDIAS2Config)
Failed to add NT Group to an SQL Role in database BAMPrimaryImport on server <server name>. (Microsoft.BizTalk.Configuration.EDIAS2.Utility)
Failed to execute SQL statement. (Microsoft.BizTalk.Configuration.ManagedConfigFrameworkHelper.ConfigHelper)
Index #: 0, Message: The database principal has granted or denied permissions to objects in the database and cannot be dropped., Line Number: 1, Source: .Net SqlClient Data Provider, Procedure: . (.Net SqlClient Data Provider)
[<Time> Info EDIAS2Config] Start rolling back changes.
[<Time> Info EDIAS2Config] Leaving function EDIAS2Config::ConfigureFeature
[<Time> Warning Configuration Framework]Feature failed to configure: MsEDIAS2.
NoteThis problem typically occurs when you have a user account in the BAMPrimaryImport database that is associated with a custom created SQL role.

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Cause

This problem occurs because of an error in BizTalk Server 2006 R2. Because of this error, BizTalk Server 2006 Configuration tries to drop a user account during the configuration.This proces fails when the user account is associated with a custom created SQL role.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: - Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2006 R2 installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatform
Edias2config.dll3.6.1476.2128,00811-Jul-200822:03x86

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about how to configure EDI/AS2 runtime by using the configuration manager, visit the following Microsoft Developer Network (MSDN) Web site:

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Keywords: KB950868, kbqfe, kbsurveynew, kbexpertiseadvanced, kbautohotfix, kbbiztalk2006r2sp1fix

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Article Info
Article ID : 950868
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 292