Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

FIX: The SIServer.exe service may consume almost 100 percent of CPU resources when the service connects to a TN3270 session in a Host Integration Server environment


View products that this article applies to.

Symptoms

The Session Integrator service (SIServer.exe) may consume almost 100 percent of CPU resources when the service connects to an IBM mainframe by using a TN3270 session in a Microsoft Host Integration Server environment.

Note This issue may occur in a Host Integration Server 2006 environment or in a Host Integration Server 2009 environment.

↑ Back to the top


Cause

This issue occurs when multiple threads from the "IO completion port thread pool" thrash back and forth as they try to service the same transport object. In this case, the high CPU usage occurs because of the locking and unlocking behind the protected transport object.

↑ Back to the top


Resolution

Microsoft Host Integration Server 2009

The hotfix that resolves this issue is included in cumulative update package 1 for Host Integration Server 2009.

For more information about how to obtain the cumulative update package, click the following article number to view the article in the Microsoft Knowledge Base:
2587090 Cumulative update package 1 for Host Integration Server 2009

Microsoft Host Integration Server 2006

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites
You must have Microsoft Host Integration Server 2006 Service Pack 1 (SP1) installed to apply this hotfix.

For more information about how to obtain the service pack, click the following article number to view the article in the Microsoft Knowledge Base:
979497 How to obtain the latest Host Integration Server 2006 service pack

Restart information
You do not have to restart the computer after you apply this hotfix.

Replacement information
This hotfix does not replace a previously released hotfix.

File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Microsoft Host Integration Server 2006, 32-bit Edition
File nameFile versionFile sizeDateTimePlatform
Siproxy.dll7.0.2898.0430,59231-Jul-200818:56x86
Siserver.exe7.0.2898.0201,21631-Jul-200818:56x86
Microsoft Host Integration Server 2006, 64-bit Edition
File nameFile versionFile sizeDateTimePlatform
Siproxy.dll7.0.2898.0605,18431-Jul-200818:58x64
Siserver.exe7.0.2898.0295,93631-Jul-200818:58x64
Note Because of file dependencies, the most recent fix that contains these files may also contain additional files.

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: kbautohotfix, kbqfe, kbhotfixserver, kbfix, kbexpertiseinter, kbsurveynew, kbbug, kb

↑ Back to the top

Article Info
Article ID : 950777
Revision : 1
Created on : 1/7/2017
Published on : 10/13/2011
Exists online : False
Views : 143