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E-mail senders do not receive an indication that some messages have been held by Exchange Server 2003 until the SMTP service, the Microsoft Exchange Information Store service, or the Exchange server is restarted


View products that this article applies to.

Symptoms

In an Exchange Server 2003 environment, after the SMTP service is restarted, the Store service is restarted, or the server is restarted, the e-mail recipients may receive old messages that were sent several days before. Or, the e-mail senders may receive Non-Delivery Report (NDR) messages for the delayed e-mail messages that they previously sent.

When this problem occurs, these messages are not visible in the SMTP queues in Exchange System Manager. However, these messages are visible the SMTP Temp tables in the mailbox store. Also, the e-mail senders do not receive an indication that the messages are held by the Exchange Server 2003 server until they receive the NDR messages when one of the services is restarted or when the server is restarted.

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Cause

When the store starts, the GuidTimestamp is generated on the store side and passed over to Internet Information Services (IIS) store driver (Drviis) through a proxy. However, in some cases, the information that contains the GuidTimestamp is sent to the store driver two times, and IIS receives a different time stamp than the Store receives. When a new message is rendered, the store stamps and submits the messages to the send queue, and then the GuidTimeStamp is changed on the IIS side. Sometimes the messages are not delivered to the next hop on the first try because a remote SMTP host has "Greylisting" enabled. In this case, the SMTP host sends a Temporary Error (4.7.1) message back to the sender that indicates that the sender should retry the transmission of a message in a few minutes. In this scenario, the message is set to a "retry" state by the SMTP service. When the �retry� happens the time stamp on the message is compared with the time stamp of the store driver. When there is a mismatch, the message is considered invalid, and it not delivered until the SMTP service or IIS is restarted.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Microsoft Exchange Server 2003 Service Pack 2 to be installed on the server because of file dependencies.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Restart requirement

The server must be restarted if the Wmiprvse.exe process is running.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTime
Drviis.dll6.5.7654.2135,68017-Jul-200817:56
Exsmtp.dll6.5.7654.2407,55217-Jul-200818:14
Gwart.dll6.5.7654.266,56017-Jul-200816:48
Phatcat.dll6.5.7654.2504,32017-Jul-200802:52
Reapi.dll6.5.7654.2848,89617-Jul-200818:14

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More information

For more information about how to use the Mfcmapi.exe utility to view and work with messages in the SMTP TempTables, click the following article number to view the article in the Microsoft Knowledge Base:
906557 How to use the Mfcmapi.exe utility to view and work with messages in the SMTP TempTables in Exchange 2000 Server and in Exchange Server 2003
For more information about the idle messages issue in a Windows Server 2003 SMTP server, click the following article number to view the article in the Microsoft Knowledge Base:
934709 On a Windows Server 2003-based SMTP gateway server, some messages may remain in the queue folder until the SMTP service is restarted

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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Keywords: KB950757, kbautohotfix, kbqfe, kbhotfixserver, kbexpertiseadvanced, kbfix

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Article Info
Article ID : 950757
Revision : 2
Created on : 1/22/2009
Published on : 1/22/2009
Exists online : False
Views : 216