Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may be unable to use the "netsh interface" context in some Server Core installations of Windows Server 2008


View products that this article applies to.

Symptoms

In some Server Core installations of Windows Server 2008, you may be unable to use the netsh interface context for the following:
  • For network interface enumeration
  • To show an interface
  • To enable or disable an interface
  • To rename an interface
For example, when you run the netsh interface show interface command at a command prompt, the system returns no registered interfaces.

This problem may occur in Server Core installations of the following versions of Windows Server 2008:
  • Windows Web Server 2008
  • Windows Server 2008 Datacenter without Hyper-V
  • Windows Server 2008 Enterprise without Hyper-V
  • Windows Server 2008 Standard without Hyper-V
Note This problem does not occur in Server Core installations of the following versions of Windows Server 2008:
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Standard

↑ Back to the top


Cause

This problem occurs because the products that appear in the second list in the "Symptoms" section do not supported enabling the netsh interface context.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ifmon.dll6.0.6001.2215129,69605-Apr-200803:18x86
Windows Server 2008, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ifmon.dll6.0.6001.2215136,35206-Apr-200803:02x64
Windows Server 2008, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ifmon.dll6.0.6001.2215175,26405-Apr-200803:36IA-64

↑ Back to the top


More information

You may be unable to enable or disable a network interface on some HP servers even after you apply this hotfix. This behavior occurs only when the HP Proliant SupportPaq program is installed. This is a known issue. HP has provided the following workaround. To work around this problem, type the following command at a command prompt, and then press ENTER:
setLACState �Local Area Connection� enable
Note The default folder location for this tool is the following folder: C:\Program Files\HP\NCU

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

↑ Back to the top


Keywords: KB950499, kbhotfixserver, kbqfe, kbfix, kbexpertiseinter, kbautohotfix

↑ Back to the top

Article Info
Article ID : 950499
Revision : 4
Created on : 4/30/2008
Published on : 4/30/2008
Exists online : False
Views : 323