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Event ID 6008 is logged in the System log even though the Windows Server 2003-based computer shuts down successfully


View products that this article applies to.

Symptoms

Even when you successfully shut down a Windows Server 2003-based computer, the following event is logged in the System log after you start the computer again:

Event type: Error
Event source: EventLog
Event category: None
Event ID: 6008
Date: Date
Time: Time
User: N/A
Computer: ComputerName
Description:
The previous system shutdown at PreviousTime on PreviousDate was unexpected.

Note This event indicates that the system was shut down unexpectedly. This event is incorrect because the system was successfully shut down.

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Cause

The Event Log service periodically updates the last alive time stamp that is stored in a registry entry. The Event Log service cleans the last alive time stamp during system shutdown. This time stamp is not cleaned after an unexpected shutdown (dirty shutdown). Then the next time that the system starts, the Event Log service raises an event to report the unexpected shutdown.

However, a race condition may occur between the timer thread and the system shutdown thread. The last alive time stamp may be reupdated after it is cleaned during system shutdown. Therefore, an "unexpected shutdown" event is reported incorrectly.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 or Windows Server 2003 Service Pack 2 installed on the computer. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100� How to obtain the latest service pack for Windows Server 2003

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Eventlog.dll5.2.3790.314369,63221-May-200815:13x86
Windows Server 2003 with Service Pack 2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Eventlog.dll5.2.3790.429869,12021-May-200815:00x86
Windows Server 2003 with Service Pack 1, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Eventlog.dll5.2.3790.3143184,32021-May-200813:03IA-64
Windows Server 2003 with Service Pack 2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Eventlog.dll5.2.3790.4298184,32021-May-200813:08IA-64
Windows Server 2003 with Service Pack 1, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Eventlog.dll5.2.3790.3143130,56021-May-200813:03x64
Windows Server 2003 with Service Pack 2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Eventlog.dll5.2.3790.4298130,56021-May-200813:08x64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbqfe, KB950323

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Article Info
Article ID : 950323
Revision : 2
Created on : 10/8/2011
Published on : 10/8/2011
Exists online : False
Views : 751