Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

The Cluster service may stop responding on a Windows Server 2008 cluster node when an application performs VSS backup of files from a volume


View products that this article applies to.

Symptoms

The Cluster service may stop responding (hang) on a Windows Server 2008 cluster node when an application performs Volume Shadow Copy Service (VSS) backup of files from a volume.

The Cluster.log file may contain information that resembles the following:
864:fb0.01/21[03:02:04.887](000000) INFO [VSS] OnIdentify - Version X-1.4 Component Name Cluster Database
864:fb0.01/21[03:02:04.887](000000) INFO [VSS] OnIdentify - Add Files To File Group target path %WINDIR%\cluster\
864:fb0.01/21[03:02:04.887](000000) INFO [VSS] OnIdentify Returned true
864:fb0.01/21[03:02:05.792](000000) ERR mscs::ClusterVssWriter::FindClusterComponent: AssertionFailed(668)' because of 'failed assertion'(compCount > 0 is false)
Additionally, the following events are logged in the Application log.

Event ID 1000

Event ID 12305

Event ID 12290

Event ID 16387

Note to developers This problem may occur if the backup application prepares the backup by using an empty IVssWriterComponents parameter.

↑ Back to the top


Cause

A pointer variable in the IsClusterWriterPresent function of the ClusterVssWriter object points to each component in the input list in turn. This variable is not initialized to NULL. If the input list is empty, this variable contains a random address. Therefore, an access violation occurs when the Cluster service tries to deallocate the random address.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running the Cluster service on the Windows Server 2008 computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Clussvc.exe6.0.6001.221512,333,18405-Apr-200800:57x86
Windows Server 2008, Itanium-based versions
File nameFile versionFile sizeDateTimePlatform
Clussvc.exe6.0.6001.221516,458,88005-Apr-200801:12IA-64
Windows Server 2008, x64-based versions
File nameFile versionFile sizeDateTimePlatform
Clussvc.exe6.0.6001.221513,857,92005-Apr-200818:29x64

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

↑ Back to the top


Keywords: kbqfe, kbhotfixserver, kbfix, kbbug, kbclustering, kbexpertiseadvanced, kbautohotfix, kb, kbexpertiseinter

↑ Back to the top

Article Info
Article ID : 950267
Revision : 2
Created on : 9/21/2018
Published on : 9/21/2018
Exists online : False
Views : 248