Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

You may be unable to open the FSRM MMC snap-in on a Windows Server 2003 R2-based computer


View products that this article applies to.

Symptoms

You may be unable to open the File Server Resource Manager (FSRM) Microsoft Management Console (MMC) snap-in on a Windows Server 2003 R2-based computer. Additionally, one of the following error messages may be logged in the Application event log:
Error message 1
Type: Error
Date: Date
Time: Time
Event ID: 4
Source: SRMSVC
User: N/A
Computer: Computer Name

Description:

File Server Resource Manager Service information: The COM Server with CLSID {efbdb74f-5b0d-4ad8-9aaf-aae0c8840a30} and name 'SrmReportManager' cannot be started.

Error: 0x80045316, The File Server Resource Manager service encountered an unexpected error.
Check the application event log for more information.
Error message 2
Type: Error
Date: Date
Time: Time
Event ID: 4
Source: SRMSVC
User: N/A
Computer: Computer Name

Description:

File Server Resource Manager Service information: The COM Server with CLSID {61b2d373-4258-40a2-89ac-2783d8ac0e99} and name 'SrmReportManagerInproc' cannot be started.
Error: 0x80131534.

↑ Back to the top


Cause

This problem occurs because the Microsoft .NET Framework 2.0 component is corrupted.

↑ Back to the top


Resolution

To resolve this problem, follow these steps:
  1. Download the .NET Framework 2.0. The following file is available for download from the Microsoft Download Center:

    Download Download the Microsoft .NET Framework Version 2.0 Redistributable Package (x64) package now.

    For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
    119591 How to obtain Microsoft support files from online services
    Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.
  2. Perform a repair installation of the .NET Framework.
  3. Restart the computer.
Note This problem also occurs with the .NET Framework 3.0. To resolve the problem, uninstall and then reinstall the .NET Framework 3.0.

↑ Back to the top


Keywords: kbexpertiseinter, kbtshoot, kbprb, kb

↑ Back to the top

Article Info
Article ID : 949920
Revision : 1
Created on : 1/7/2017
Published on : 10/17/2012
Exists online : False
Views : 360