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The BizTalk Server SAP adapter stops receiving IDOC messages in BizTalk Server


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Symptoms

Consider the following scenario. You are using Microsoft BizTalk Server. You send an IDOC message. An IDOC message is an intermediate SAP document from the SAP system to the server that is running BizTalk Server. The BizTalk Server SAP adapter stops receiving IDOC messages, and the following error may be logged in the event log:

Error in Check Transaction: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.

Additionally, BizTalk Server receives the IDOC messages if the BizTalk Server host is restarted or if the blocking process on the server that is running Microsoft SQL Server is killed.

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Cause

This problem occurs because the index on the SAPTid table that is used by the BizTalk Server SAP adapter is not available.

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Workaround

To work around this problem, the index for the SAPTid table must be created. Ask the database administrator to run the following SQL script in the MessageBox database.
 
create unique clustered index SAPTid_clusteredIndex_RfcTID ON SAPTid (RfcTID)

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Keywords: kbexpertiseadvanced, kbtshoot, kbsurveynew, kbprb, KB949855

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Article Info
Article ID : 949855
Revision : 1
Created on : 3/24/2009
Published on : 3/24/2009
Exists online : False
Views : 401