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The IPMI SEL viewer utility is incorrectly disabled in Windows Server 2008 if the BMC interrupt is enabled in BIOS


View products that this article applies to.

Symptoms

The Intelligent Platform Management Interface (IPMI) System Event Log (SEL) viewer utility is incorrectly disabled in Windows Server 2008 if the baseboard management controller (BMC) interrupt is enabled in BIOS. After the IPMI SEL viewer utility is disabled, no error information is logged if hardware failure occurs. This issue may cause problems for hardware vendors that depend on the IPMI SEL viewer utility to troubleshoot hardware issues.

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Cause

This issue occurs only if the BMC interrupt feature is enabled. The IPMI driver (Ipmidrv.sys) enables the BMC interrupt feature by sending the Set BMC Global Enables command. This command also disables the SEL viewer utility. When the SEL viewer utility is disabled, BMC does not log any errors when a hardware failure occurs.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires that you have Windows Server 2008 installed on the computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2008, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ipmidrv.infNot Applicable4,92026-Feb-200800:45Not Applicable
Ipmidrv.sys6.0.6001.2212264,51226-Feb-200803:11x86
Windows Server 2008, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ipmidrv.infNot Applicable4,94426-Feb-200800:47Not Applicable
Ipmidrv.sys6.0.6001.2212276,28826-Feb-200803:44x64
Windows Server 2008, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ipmidrv.infNot Applicable4,93226-Feb-200800:45Not Applicable
Ipmidrv.sys6.0.6001.22122161,79226-Feb-200803:35IA-64

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The IPMI server management system is defined by Intel together with a consortium of promoters. This consortium also includes Dell, Hewlett-Packard (HP), and NEC. IPMI provides server monitoring and management features.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Keywords: KB949425, kbexpertiseinter, kbqfe, kbhotfixserver, kbautohotfix

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Article Info
Article ID : 949425
Revision : 3
Created on : 5/20/2008
Published on : 5/20/2008
Exists online : False
Views : 396