Notice: This website is an unofficial Microsoft Knowledge Base (hereinafter KB) archive and is intended to provide a reliable access to deleted content from Microsoft KB. All KB articles are owned by Microsoft Corporation. Read full disclaimer for more details.

Event ID 1014 and Event 1005 are logged in the Application log after you use an SSL certificate for Exchange virtual server on an Exchange Server 2003-based cluster


View products that this article applies to.

Symptoms

When you install and use a Secure Socket Layer (SSL) certificate on the Exchange Virtual Server Web site that is hosted on a clustered Exchange 2003 mailbox server, the Resrcmon.exe process and the Lsass.exe process may encounter high CPU usage issue on the server. This high CPU usage issue will eventually lead to cluster failover. Additionally, the following events are logged in the Application log:


Event Type: Error
Event Source: MSExchangeCluster
Event Category: None
Event ID: 1014
Description: Exchange HTTP Virtual Server Instance xx (<computer name>): IsAlive checking for this resource failed due to timeout.

Event Type: Error
Event Source: MSExchangeCluster
Event Category: None
Event ID: 1005
Description: Exchange HTTP Virtual Server Instance xx (<computer name>): IsAlive checking for this resource failed due to timeout.

↑ Back to the top


Cause

This issue occurs when the SSL certificate is larger than the maximum packet size for the network. This maximum packet size for the network is known as the MTU (Maximum Transmission Unit). In this situation, if the Resrcmon.exe process or the Lsass.exe process calls the Exres.dll file to perform the IsAlive check over the SSL protocol, an infinite loop occurs in the Exres.dll file. This infinite loop results in the high CPU usage issue for corresponding processes.

↑ Back to the top


Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Microsoft Exchange Server 2003 Service Pack 2 to be installed on the server because of file dependencies. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 � How to obtain the latest service packs for Exchange Server 2003

Restart requirement

You do not have to restart the computer after you apply this hotfix. However, you want to stop Cluster service before you apply this hotfix on the passive node.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Collapse this tableExpand this table
File nameFile versionFile sizeDateTime
Exres.dll6.5.7653.36134,65623-May-200816:34

↑ Back to the top


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

↑ Back to the top


Keywords: KB949412, kbqfe, kbhotfixserver, kbexpertiseinter, kbexchcluster, kbautohotfix

↑ Back to the top

Article Info
Article ID : 949412
Revision : 2
Created on : 6/5/2008
Published on : 6/5/2008
Exists online : False
Views : 299