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Error messages when you try to install Windows XP Service Pack 3: "Service Pack 3 installation did not complete" and "An internal error occurred"


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Symptoms

When you try to install Windows XP Service Pack 3 (SP3), you may receive the following error message:
An internal error occurred
After you click OK in the error message, you receive the following error message:
Service Pack 3 installation did not complete
Additionally, you may see the following errors that are logged in the C:\Windows\Svcpack.log file:
165.672: An internal error occurred.
165.672: Service Pack 3 installation did not complete.
165.672: Update.exe extended error code = 0x1ffe054f
165.672: Update.exe return code was masked to 0x643 for MSI custom action compliance
Note Throughout this article, the C:\Windows folder represents the folder where Windows XP is typically installed.

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Cause

The errors that are mentioned in the "Symptoms" section can occur because of files that are not trusted or because of corrupted registry keys. You can verify the cause by searching for related entries in the Svcpack.log file. Specific entries will identify specific causes of the issue, as noted in the following "Cause" sections.

Cause 1

Determine whether the following entries are logged in the Svcpack.log file:
142.391: CheckVLKForBlock: LIC.dll not trust verified
142.578: Trying CheckVLKForBlock again
142.594: CheckVLKForBlock: LIC.dll not trust verified
142.594: Error: CheckVLKForBlock failed
These entries indicate that the cause of the issue is the Licdll.dll file. The Licdll.dll file may have been altered, is corrupted, or is not trusted. The Licdll.dll file is located in the following folder:
C:\Windows\System32\

Cause 2

Determine whether the following entries are logged in the Svcpack.log file:
211.890: IsSPBetaKey:pLA->lpVtbl->GetProductID Failed: 0x80004005 
213.125: Trying CheckVLKForBlock again
214.468: Error: CheckVLKForBlock failed
These entries indicate that incorrect product ID information in the registry is causing the issue.

Cause 3

Determine whether the following entries are logged in the Svcpack.log file:
299.031: Trying CheckVLKForBlock again
299.531: Error: CheckVLKForBlock failed
These entries indicate that corrupted or altered registry keys in preinstalled programs are causing the issue.

Note One program that is known to cause this issue is Micrografx - Picture Publisher Professional 10. To work around this issue, see the "Workaround for Cause 3" section.

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Resolution

To resolve or to work around these causes, use the resolution or the workaround that corresponds to the cause.

Resolution for Cause 1

To resolve this issue, you must replace the current copy of the Licdll.dll file by using a copy from the original Windows XP media. To do this, follow these steps:
  1. Insert the Windows XP CD into the CD drive.
  2. Click Exit on the Setup Wizard as soon as it starts.
  3. Click Start, and then click Run.
  4. Copy and then paste (or type) the following command in the Open box, and then press ENTER:
    explorer
  5. Click My Computer.
  6. Note the drive letter that contains the Windows XP CD.
  7. Click Start, and then click Run.
  8. Copy and then paste (or type) the following command in the Open box, and then press ENTER:
    cmd
  9. Type or copy and paste the following text into the Command Prompt window, and then press ENTER:
    Expand CD_Drive_Letter:\i386\licdll.dl_ C:\Windows\system32\Licdll.dll
    Note In the command in step 9, replace CD_Drive_Letter by using the actual drive letter for the drive that you noted in step 6.
  10. To install Windows XP SP3, visit the following Microsoft Windows Update Web site:

Resolution for Cause 2

To resolve this issue, you must replace the incorrect product ID registry entry with the correct product ID. To do this, follow the steps in the "Locate and note the product ID" and "Identify and change the product ID registry entry" sections.

Locate and note the product ID

  1. Click Start, and then click Run.
  2. Copy and then paste (or type) the following command in the Open box, and then press ENTER:
    sysdm.cpl
  3. On the General tab locate the product ID. The product ID is the 20 digit number that is located under the Registered to section.
  4. Note the product ID for use in the "Identify and change the product ID registry entry" section.

Identify and change the product ID registry entry

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows
  1. Click Start, and then click Run.
  2. Copy and then paste (or type) the following command in the Open box, and then press ENTER:
    regedit
  3. Locate and then click the registry subkey that resembles the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\WPA\Key-XXXXXXXXXXXXXXXXXXXXX
    Note The series of Xs represent a placeholder for a string of 21 characters.
  4. There may be several subkeys that resemble the format in step 3. To determine the correct subkey, follow these steps:
    1. Click each subkey in the navigation pane.
    2. In the details pane, compare the value of the string for the ProductID registry entry under the Data column to the number that you noted in step 4 in the "Locate and note the product ID" section.
    3. The registry subkey whose ProductID registry entry value matches the number that you noted in the "Locate the product ID" section is the registry subkey that you want.
  5. In the navigation pane, right-click the registry subkey that you identified in step 4c, and then click Export.
  6. Save the registry subkey to the Desktop as temp.reg.
  7. Right-click the temp.reg file on the Desktop, and then click Open With.
  8. Click Notepad, and then click OK.
  9. In the open temp.reg file, locate the following text:
    [HKEY_LOCAL_MACHINE\SYSTEM\WPA\Key-XXXXXXXXXXXXXXXXXXXXX]
  10. Replace the text that is mentioned in step 9 by using the following text:
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion]
  11. Click File, click Save, and then exit Notepad.
  12. Double-click the temp.reg file, click Yes in the dialog box when you are prompted to add the information to the registry, and then click OK.
  13. To install Windows XP SP3, visit the following Microsoft Windows Update Web site:

Resolution for Cause 3

To resolve this issue, you must delete the InprocServer32 registry subkey. To do this, follow these steps:
  1. Click Start, and then click Run.
  2. Copy and then paste (or type) the following command in the Open box, and then press ENTER:
    regedit
  3. Locate and then click the registry subkey that resembles the following registry subkey:
    HKEY_CLASSES_ROOT\CLSID\{00020420-0000-0000-C000-000000000046}\InprocServer32
  4. Click InprocServer32. A string value with the name InprocServer32 is displayed in the details pane. Click this value.
  5. On the Edit menu, click Delete, and then click Yes.
  6. Exit Registry Editor.
  7. To install Windows XP SP3, visit the following Microsoft Windows Update Web site:

Workaround for Cause 3

One program that is known to cause the issue that is mentioned in Cause 3 is Micrografx - Picture Publisher Professional 10. To work around this issue, temporarily uninstall the Micrografx program, and then install Windows XP SP3. After Windows XP SP3 installation is complete, reinstall the Micrografx program.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Keywords: kbdll, kbservicepack, kbregistry, kbupdate, kbexpertisebeginner, kbprb, kberrmsg, kbtshoot, KB949384

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Article Info
Article ID : 949384
Revision : 1
Created on : 6/21/2014
Published on : 6/21/2014
Exists online : False
Views : 791