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The BizTalk host instance may recycle unexpectedly under high-load conditions in BizTalk Server 2006


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Symptoms

In Microsoft BizTalk Server 2006, the BizTalk host instance may recycle unexpectedly under high-load conditions. When this problem occurs, you may receive an error message in the Application log. The error message resembles one of the following:

Error message 1
An error occurred that requires the BizTalk service to terminate. The most common causes are the following:

1) An unexpected out of memory error.
OR
2) An inability to connect or a loss of connectivity to one of the BizTalk databases. The service will shutdown and auto-restart in 1 minute. If the problematic database remains unavailable, this cycle will repeat.

Error message: Error message: [DBNETLIB][ConnectionOpen (PreLoginHandshake()).]General network error. Check your network documentation.

Error source:

BizTalk host name: BizTalkServerApplication
Windows service name: BTSSvc$BizTalkServerApplication
Error message 2
An error occurred that requires the BizTalk service to terminate. The most common causes are the following:

1) An unexpected out of memory error.
OR
2) An inability to connect or a loss of connectivity to one of the BizTalk databases. The service will shutdown and auto-restart in 1 minute. If the problematic database remains unavailable, this cycle will repeat.

Error message: Error message: [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.

Error source:

BizTalk host name: BizTalkServerApplication
Windows service name: BTSSvc$BizTalkServerApplication
Error message 3
An error occurred that requires the BizTalk service to terminate. The most common causes are the following:

1) An unexpected out of memory error.
OR
2) An inability to connect or a loss of connectivity to one of the BizTalk databases. The service will shutdown and auto-restart in 1 minute. If the problematic database remains unavailable, this cycle will repeat.

Error message: [DBNETLIB][ConnectionOpen (Invalid Connection()).]Invalid connection.

Error source:

BizTalk host name: BizTalkServerApplication
Windows service name: BTSSvc$BizTalkServerApplication
Error message 4
An error occurred that requires the BizTalk service to terminate. The most common causes are the following:

1) An unexpected out of memory error.
OR
2) An inability to connect or a loss of connectivity to one of the BizTalk databases. The service will shutdown and auto-restart in 1 minute. If the problematic database remains unavailable, this cycle will repeat.

Error message: Timeout expired

Error source:

BizTalk host name: BizTalkServerApplication
Windows service name: BTSSvc$BizTalkServerApplication
Error message 5
Reading error. Exception information: TDDS failed to read from source database. SQLServer: SQLServer, Database: BiztalkMsgboxdb. Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
Additionally, you may receive an error message in the Microsoft SQL Server logs that resembles the following.

Note You receive this error message when trace flag 4029 is enabled.
Network error code 0x2746 occurred while establishing a connection; the connection has been closed. This may have been caused by client or server login timeout expiration. Time spent during login: total 881 ms, enqueued 551 ms, network writes 330 ms, network reads 3 ms.
Additionally, the lost connection to the server that is running SQL Server may cause other symptoms. For example, a Microsoft Distributed Transaction Coordinator (MS DTC) transaction may be stopped. If an MS DTC transaction is stopped, you may receive an error message that resembles one of the following:

Error message 1
Attempting to recover in-doubt distributed transactions involving Microsoft Distributed Transaction Coordinator (MS DTC). This is an informational message only. No user action is required.
Error message 2
Error: 8510, Severity: 20, State: 2.
Enlist operation failed: 0x8004d00e(XACT_E_NOTRANSACTION). SQL Server could not register with Microsoft Distributed Transaction Coordinator (MS DTC) as a resource manager for this transaction. The transaction may have been stopped by the client or the resource manager.

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Cause

This problem may occur because of one of the problems that are documented in the following articles in the Microsoft Knowledge Base:
927396 Queries take a longer time to finish running when the size of the TokenAndPermUserStore cache grows in SQL Server 2005
933564 FIX: A gradual increase in memory consumption for the USERSTORE_TOKENPERM cache store occurs in SQL Server 2005

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Resolution

To resolve this problem, follow these steps:
  1. Download and then install Microsoft SQL Server 2005 Service Pack 2. For more information about how to obtain SQL Server 2005 Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
    913089 How to obtain the latest service pack for SQL Server 2005
  2. Download and then install the latest cumulative update for SQL Server 2005 Service Pack 2. For more information about how to obtain the latest cumulative package for SQL Server 2005 Service Pack 2, click the following article number to view the article in the Microsoft Knowledge Base:
    937137 The SQL Server 2005 builds that were released after SQL Server 2005 Service Pack 2 was released

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Workaround

To work around this problem, turn on trace flag 4618 for the instance of SQL Server that hosts the BizTalk databases. To do this, follow these steps:
  1. Click Start, click Run, type sqlservermanager.msc, and then click OK.
  2. Click SQL Server 2005 Services.
  3. Right-click SQL Server (InstanceName), and then click Properties.
  4. At the end of the existing string in the Startup Parameters box on the Advanced tab, type -T4618, and then click OK.
  5. Restart the SQL Server service.

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More information

To troubleshoot this problem, run the following command against the instance of SQL Server that hosts the BizTalk databases:
SELECT SUM(single_pages_kb + multi_pages_kb) AS 
   "CurrentSizeOfTokenCache(kb)" 
   FROM sys.dm_os_memory_clerks 
   WHERE name = 'TokenAndPermUserStore' 
If the value that is returned increases when you run the command again, you may be experiencing one of the problems that are described in the Microsoft Knowledge Base articles that are listed in the "Cause" section. Refer to those articles to determine the problem that you are experiencing.

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Keywords: kbbts, kbtshoot, kbprb, KB949298

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Article Info
Article ID : 949298
Revision : 3
Created on : 3/4/2008
Published on : 3/4/2008
Exists online : False
Views : 504