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A 45-second delay occurs when a Windows Server 2003-based computer runs disk re-enumeration operations after you install hotfix 935949 or a later version of Virtual Disk Service (Vds.exe)


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You are running a Windows Server 2003-based computer.
  • You install hotfix 935949 or a later version of Virtual Disk Service (Vds.exe) than the version that is included in hotfix 935949.

    Note For more information about hotfix 935949, see the "References" section.
In this scenario, a 45-second delay occurs during the disk re-enumeration operation.

If the VDS calls take a long time to run, you can enable VDS logging to determine whether these calls are triggering re-enumeration. For more information about how to enable VDS logging, see the "References" section.

If the calls to the Reenumerate function and the time that is shown in the log correlate with the VDS calls that take a long time to run, the VDS log will show a delay in the Renumerate function. This delay resembles the following:
(PID:4512,TID:1904,15:34:35) ENTER CVdsService::Reenumerate()
(PID:4512,TID:1904,15:34:35) ENTER CVdsService::WaitForServiceReady()
(PID:4512,TID:1904,15:34:35) LEAVE CVdsService::WaitForServiceReady()
(PID:4512,TID:1904,15:35:20) LEAVE CVdsService::Reenumerate()

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Cause

This delay in the Renumerate function is necessary to make sure that each re-enumeration call triggers a storage rescan. Without this delay, re-enumeration calls might not find new disks as expected.

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Resolution

Some applications that require that VDS calls be completed quickly may be severely affected by this 45-second delay. To enable compatibility with these applications, a hotfix is available to circumvent this delay. This hotfix introduces a registry entry. By modifying this registry entry, you can enable or disable the delay.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) or Windows Server 2003 Service Pack 2 (SP2) installed.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756� How to back up and restore the registry in Windows
To enable this hotfix, follow these steps:
  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VDS
  3. On the Edit menu, point to New, and then click DWORD value.
  4. Type DisableReenumDelay as the new entry name.
  5. Right-click DisableReenumDelay, and then click Modify.
  6. In the Value data box, type 1, and then click OK.
  7. Exit Registry Editor.
The value of the registry entry is read when the service is loaded. Therefore, you must restart the VDS service to make the value active.

To disable this hotfix, set the value of the DisableReenumDelay registry entry to zero (0).

You cannot disable this delay on a per-application basis. You can disable this delay only on a per-system basis. By changing this value, disk changes may not be found by the Reenumerate calls. Therefore, the applications that rely on VDS notifications to find new disks may not receive these notifications. Some applications may not work correctly if they do not receive notifications of disk arrivals or of disk removals. Therefore, make sure that you modify this registry entry.

If an application can recognize which disks are supposed to be available, the application may be able to work around these lost notifications by verifying whether a disk is detected. For example, when an application masks or unmasks a Logical Unit Number (LUN), the application may recognize which disks should be available. Therefore, we recommend that you use this hotfix only when the following conditions are true:
  • The applications that use VDS can work around the lost notifications.
  • No other applications use VDS to find disk arrivals and disk removals.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP1, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Vds.exe5.2.3790.3094359,42421-Feb-200809:31x86SP1
Vdsbas.dll5.2.3790.3094147,96826-Feb-200815:27x86SP1
Vdsdyndr.dll5.2.3790.3094326,14426-Feb-200815:27x86SP1
Vdshba_i.mofNot Applicable13,96709-Dec-200717:34Not ApplicableSP1
Vdshba_u.mofNot Applicable34509-Dec-200717:34Not ApplicableSP1
Vdsldr.exe5.2.3790.309419,45621-Feb-200809:31x86SP1
Vdsutil.dll5.2.3790.309462,97626-Feb-200815:27x86SP1
Vds_ps.dll5.2.3790.309430,72026-Feb-200815:27x86SP1
Windows Server 2003 with SP2, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirement
Vds.exe5.2.3790.4242359,42422-Feb-200811:53x86SP2
Vdsbas.dll5.2.3790.4242147,96826-Feb-200813:28x86SP2
Vdsdyndr.dll5.2.3790.4242326,65626-Feb-200815:08x86SP2
Vdsldr.exe5.2.3790.424219,45622-Feb-200811:52x86SP2
Vdsutil.dll5.2.3790.424262,97626-Feb-200815:08x86SP2
Vds_ps.dll5.2.3790.424230,72026-Feb-200815:08x86SP2
Windows Server 2003 with SP1, IA-64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vds.exe5.2.3790.30941,172,48026-Feb-200813:22IA-64SP1Not Applicable
Vdsbas.dll5.2.3790.3094503,80826-Feb-200813:22IA-64SP1Not Applicable
Vdsdyndr.dll5.2.3790.3094766,97626-Feb-200813:22IA-64SP1Not Applicable
Vdshba_i.mofNot Applicable13,96726-Feb-200813:22Not ApplicableSP1Not Applicable
Vdshba_u.mofNot Applicable34526-Feb-200813:22Not ApplicableSP1Not Applicable
Vdsldr.exe5.2.3790.309463,48826-Feb-200813:22IA-64SP1Not Applicable
Vdsutil.dll5.2.3790.3094175,10426-Feb-200813:22IA-64SP1Not Applicable
Vds_ps.dll5.2.3790.309445,56826-Feb-200813:22IA-64SP1Not Applicable
Wvds_ps.dll5.2.3790.309430,72026-Feb-200813:22x86SP1WOW
Windows Server 2003 with SP2, IA-64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vds.exe5.2.3790.42421,172,48026-Feb-200813:26IA-64SP2Not Applicable
Vdsbas.dll5.2.3790.4242504,32026-Feb-200813:26IA-64SP2Not Applicable
Vdsdyndr.dll5.2.3790.4242768,51226-Feb-200813:26IA-64SP2Not Applicable
Vdsldr.exe5.2.3790.424263,48826-Feb-200813:26IA-64SP2Not Applicable
Vdsutil.dll5.2.3790.4242175,10426-Feb-200813:26IA-64SP2Not Applicable
Vds_ps.dll5.2.3790.424245,56826-Feb-200813:26IA-64SP2Not Applicable
Wvds_ps.dll5.2.3790.424230,72026-Feb-200813:26x86SP2WOW
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vds.exe5.2.3790.3094623,61626-Feb-200813:23x64SP1Not Applicable
Vdsbas.dll5.2.3790.3094263,68026-Feb-200813:23x64SP1Not Applicable
Vdsdyndr.dll5.2.3790.3094456,19226-Feb-200813:23x64SP1Not Applicable
Vdshba_i.mofNot Applicable13,96726-Feb-200813:23Not ApplicableSP1Not Applicable
Vdshba_u.mofNot Applicable34526-Feb-200813:23Not ApplicableSP1Not Applicable
Vdsldr.exe5.2.3790.309429,69626-Feb-200813:23x64SP1Not Applicable
Vdsutil.dll5.2.3790.309495,23226-Feb-200813:23x64SP1Not Applicable
Vds_ps.dll5.2.3790.309441,47226-Feb-200813:23x64SP1Not Applicable
Wvds_ps.dll5.2.3790.309430,72026-Feb-200813:23x86SP1WOW
Windows Server 2003 with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Vds.exe5.2.3790.4242623,61626-Feb-200813:29x64SP2Not Applicable
Vdsbas.dll5.2.3790.4242264,19226-Feb-200813:29x64SP2Not Applicable
Vdsdyndr.dll5.2.3790.4242456,70426-Feb-200813:29x64SP2Not Applicable
Vdsldr.exe5.2.3790.424229,69626-Feb-200813:29x64SP2Not Applicable
Vdsutil.dll5.2.3790.424295,23226-Feb-200813:29x64SP2Not Applicable
Vds_ps.dll5.2.3790.424241,47226-Feb-200813:29x64SP2Not Applicable
Wvds_ps.dll5.2.3790.424230,72026-Feb-200813:29x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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References

For more information about how to enable VDS logging, click the following article number to view the article in the Microsoft Knowledge Base:
842011� How to turn on logging for the VDS in Windows Server 2003
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935949� The Virtual Disk Service (VDS) in Windows Server 2003 does not return port-specific identifiers for a storage device

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Keywords: kbautohotfix, kbexpertiseadvanced, kbfix, kbpubtypekc, kbqfe, kbhotfixserver, KB949002

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Article Info
Article ID : 949002
Revision : 2
Created on : 3/25/2008
Published on : 3/25/2008
Exists online : False
Views : 247