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A program that allocates a large block of contiguous memory may not start or may intermittently fail in Windows Server 2003 with Service Pack 2


View products that this article applies to.

Symptoms

Consider the following scenario:
  • You have a program that allocates a large block of contiguous memory in Windows Server 2003 with Service Pack 2 (SP2). For example, this program allocates a 1.5-gigabyte (GB) block of memory when the program starts or after it starts.
  • This program loads the Hnetcfg.dll library.
In this scenario, the program may not start. Or, after the program starts, it may intermittently fail. If you troubleshoot these program failures, you may find that the program could not successfully allocate the large block of contiguous memory.

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Cause

This problem occurs because the Hnetcfg.dll library has an image base address of 5F270000. If the Hnetcfg.dll library is loaded at this address, memory fragmentation of the Windows user address space may occur. You experience this fragmentation because the Hnetcfg.dll library is loaded at approximately 1.6 GB into the address space.

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Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 SP2 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix replaces hotfix 913409.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with Service Pack 2 (SP2), x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Hnetcfg.dll5.2.3790.4243355,32828-Feb-200811:53x86
Windows Server 2003 with SP2, Itanium-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hnetcfg.dll5.2.3790.42431,104,38428-Feb-200809:44IA-64SP2Not Applicable
Whnetcfg.dll5.2.3790.4243355,32828-Feb-200809:44x86SP2WOW
Windows Server 2003, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hnetcfg.dll5.2.3790.4243581,63228-Feb-200809:47x64SP2Not Applicable
Whnetcfg.dll5.2.3790.4243355,32828-Feb-200809:47x86SP2WOW
Windows XP with SP2, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Hnetcfg.dll5.2.3790.4243581,63228-Feb-200809:47x64SP2Not Applicable
Whnetcfg.dll5.2.3790.4243355,32828-Feb-200809:47x86SP2WOW

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Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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More information

The same problem occurs in the release version of Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
913409� A program that allocates a large block of contiguous memory may not start or may intermittently fail in Windows Server 2003

Technical support for x64-based versions of Microsoft Windows

If your hardware came with a Microsoft Windows x64 edition already installed, your hardware manufacturer provides technical support and assistance for the Windows x64 edition. In this case, your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation by using unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you must have technical help with a Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware. If you purchased a Windows x64 edition such as a Windows Server 2003 x64 edition separately, contact Microsoft for technical support.

For product information about Windows XP Professional x64 Edition, visit the following Microsoft Web site: For product information about x64-based versions of Windows Server 2003, visit the following Microsoft Web site:

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References

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684� Description of the standard terminology that is used to describe Microsoft software updates

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Keywords: kbautohotfix, kbexpertiseinter, kbwinserv2003postsp2fix, kbbug, kbfix, kbhotfixserver, kbqfe, KB948656

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Article Info
Article ID : 948656
Revision : 3
Created on : 3/11/2008
Published on : 3/11/2008
Exists online : False
Views : 246